How Many Equations Can You Find HDU - 2266

题目链接:点这里

Now give you an string which only contains 0, 1 ,2 ,3 ,4 ,5 ,6 ,7 ,8 ,9.You are asked to add the sign ‘+’ or ’-’ between the characters. Just like give you a string “12345”, you can work out a string “123+4-5”. Now give you an integer N, please tell me how many ways can you find to make the result of the string equal to N .You can only choose at most one sign between two adjacent characters.

Input

Each case contains a string s and a number N . You may be sure the length of the string will not exceed 12 and the absolute value of N will not exceed 999999999999.

Output

The output contains one line for each data set : the number of ways you can find to make the equation.

Sample Input

123456789 3
21 1

Sample Output

18
1

题意:

    给你一个字符串s和一个数字n,你能有这个字符串能有多少方式组成这个数字

思路:

简单题,直接暴力深搜就可以出答案了

代码:

#include<iostream>
#include<cstring>
#include<cstdio>
#include<algorithm>
#include<cmath>
using namespace std;

char s[20];
int a[20][20];
int n,m;
int ans;

void init()
{
    memset(a,0,sizeof(a));
    m=strlen(s);
    for(int i=0;i<m;++i){
        a[i][i]=s[i]-'0';
        for(int j=i+1;j<m;++j){
            a[i][j]=a[i][j-1]*10+s[j]-'0';
        }
    }
}

void dfs(int i,int num)
{
    if(i==m){
        if(num==n)
            ++ans;
        return ;
    }
    for(int j=i;j<m;++j){
        dfs(j+1,num+a[i][j]);
        dfs(j+1,num-a[i][j]);
    }
}

int main()
{
    while(scanf("%s %d",s,&n)!=EOF){
        init();
        ans=0;
        m=strlen(s);
        for(int i=0;i<m;++i){
            dfs(i+1,a[0][i]);
        }
        cout<<ans<<endl;
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值