*dfs: Cannon

Description
In Chinese Chess, there is one kind of powerful chessmen called Cannon. It can move horizontally or vertically along the chess grid. At each move, it can either simply move to another empty cell in the same line without any other chessman along the route or perform an eat action. The eat action, however, is the main concern in this problem.
An eat action, for example, Cannon A eating chessman B, requires two conditions:
1、A and B is in either the same row or the same column in the chess grid.
2、There is exactly one chessman between A and B.
Here comes the problem.
Given an N x M chess grid, with some existing chessmen on it, you need put maximum cannon pieces into the grid, satisfying that any two cannons are not able to eat each other. It is worth nothing that we only account the cannon pieces you put in the grid, and no two pieces shares the same cell.
Input
There are multiple test cases.
In each test case, there are three positive integers N, M and Q (1<= N, M<=5, 0<=Q <= N x M) in the first line, indicating the row number, column number of the grid, and the number of the existing chessmen.
In the second line, there are Q pairs of integers. Each pair of integers X, Y indicates the row index and the column index of the piece. Row indexes are numbered from 0 to N-1, and column indexes are numbered from 0 to M-1. It guarantees no pieces share the same cell.
Output
There is only one line for each test case, containing the maximum number of cannons.
Sample Input
4 4 2
1 1 1 2
5 5 8
0 0 1 0 1 1 2 0 2 3 3 1 3 2 4 0
Sample Output
8
9

#include <cstdio>
#include <algorithm>
#include <cstring>
using namespace std;
int mp[10][10],n,m,q,ans;
void dfs(int x,int y,int cnt)
{
    if(x>=n)
    {
        ans=max(ans,cnt);
        return;
    }
    if(y>=m)
    {
        dfs(x+1,0,cnt);
        return;
    }
    if(mp[x][y])
    {
        dfs(x,y+1,cnt);
        return;
    }
    dfs(x,y+1,cnt);//不放置炮
    int flag=0,i;
    for(i=x-1; i>=0; i--)
        if(mp[i][y])
            break;
    for(int j=i-1; j>=0; j--)
        if(mp[j][y])
        {
            if(mp[j][y]==2)
                flag=1;
            break;
        }
    if(flag)
        return;
    for(i=y-1; i>=0; i--)
        if(mp[x][i])
            break;
    for(int j=i-1; j>=0; j--)
        if(mp[x][j])
        {
            if(mp[x][j]==2)
                flag=1;
            break;
        }
    if(flag)
        return;
    mp[x][y]=2;
    dfs(x,y+1,cnt+1);//放置炮
    mp[x][y]=0;//回溯
}
int main()
{
    while(~scanf("%d%d%d",&n,&m,&q))
    {
        ans=0;
        memset(mp,0,sizeof mp);
        while(q--)
        {
            int a,b;
            scanf("%d%d",&a,&b);
            mp[a][b]=1;
        }
        dfs(0,0,0);
        printf("%d\n",ans);
    }
    return 0;
}
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值