map+树状数组+离线:Turing Tree

Description
After inventing Turing Tree, 3xian always felt boring when solving problems about intervals, because Turing Tree could easily have the solution. As well, wily 3xian made lots of new problems about intervals. So, today, this sick thing happens again…

Now given a sequence of N numbers A1, A2, …, AN and a number of Queries(i, j) (1≤i≤j≤N). For each Query(i, j), you are to caculate the sum of distinct values in the subsequence Ai, Ai+1, …, Aj.
Input
The first line is an integer T (1 ≤ T ≤ 10), indecating the number of testcases below.
For each case, the input format will be like this:
* Line 1: N (1 ≤ N ≤ 30,000).
* Line 2: N integers A1, A2, …, AN (0 ≤ Ai ≤ 1,000,000,000).
* Line 3: Q (1 ≤ Q ≤ 100,000), the number of Queries.
* Next Q lines: each line contains 2 integers i, j representing a Query (1 ≤ i ≤ j ≤ N).
Output
For each Query, print the sum of distinct values of the specified subsequence in one line.
Sample Input
2
3
1 1 4
2
1 2
2 3
5
1 1 2 1 3
3
1 5
2 4
3 5
Sample Output
1
5
6
3
6

离线操作:
不是边输入查询区间边输出结果,而是输入完查询区间后,在一起将结果输出;
由于要去重,将区间按照右端点大小排序,计算的时候将之前的重复出现的数字删掉,保证了参加计算数字的不重复性;

#include <cstdio>
#include <algorithm>
#include <cstring>
#include <map>
using namespace std;
const int maxn=30009;
long long a[maxn],ans[1000009],c[maxn],n;
map<int,int> mp;//记录数字上次出现的位置

struct node
{
    int l,r,id;
} qu[100009];
int cmp(node a,node b)
{
    return a.r<b.r;//查询按照区间右端点排序
}
int lowbit(int x)
{
    return x&-x;
}
void update(int pos,int val)
{
    while(pos<=n) c[pos]+=val,pos+=lowbit(pos);
}
long long query(int pos)
{
    long long ret=0;
    while(pos>0)  ret+=c[pos],pos-=lowbit(pos);
    return ret;
}

int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d",&n);
        for(int i=1; i<=n; i++)
            scanf("%d",&a[i]);
        int q;
        scanf("%d",&q);
        for(int i=1; i<=q; i++)
        {
            scanf("%d%d",&qu[i].l,&qu[i].r);
            qu[i].id=i;
        }
        sort(qu+1,qu+1+q,cmp);
        mp.clear();
        memset(c,0,sizeof c);
        int j=1;
        for(int i=1; i<=q; i++)
        {
            while(j<=qu[i].r)
            {
                if(!mp[a[j]])
                    update(j,a[j]);
                else
                {
                  update(mp[a[j]],-a[j]);//若在之前已经出现过,那么将之前位置的数字删掉,然后在新的位置插入
                  update(j,a[j]);
                }
                mp[a[j]]=j,j++;
            }
            ans[qu[i].id]=query(qu[i].r)-query(qu[i].l-1);
        }
        for(int i=1; i<=q; i++)
            printf("%I64d\n",ans[i]);
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值