1128 N Queens Puzzle (20分)

The “eight queens puzzle” is the problem of placing eight chess queens on an 8×8 chessboard so that no two queens threaten each other. Thus, a solution requires that no two queens share the same row, column, or diagonal. The eight queens puzzle is an example of the more general N queens problem of placing N non-attacking queens on an N×N chessboard. (From Wikipedia - “Eight queens puzzle”.)

Here you are NOT asked to solve the puzzles. Instead, you are supposed to judge whether or not a given configuration of the chessboard is a solution. To simplify the representation of a chessboard, let us assume that no two queens will be placed in the same column. Then a configuration can be represented by a simple integer sequence (Q1 ,Q2,⋯,QN), where Qi is the row number of the queen in the i-th column. For example, Figure 1 can be represented by (4, 6, 8, 2, 7, 1, 3, 5) and it is indeed a solution to the 8 queens puzzle; while Figure 2 can be represented by (4, 6, 7, 2, 8, 1, 9, 5, 3) and is NOT a 9 queens’ solution.
Figure 1
Figure 1
Figure 2
Figure 2

Input Specification:

Each input file contains several test cases. The first line gives an integer K (1<K≤200). Then K lines follow, each gives a configuration in the format “N Q​1 Q​2 … Q​N”, where 4≤N≤1000 and it is guaranteed that 1≤Q​i ≤N for all i=1,⋯,N. The numbers are separated by spaces.

Output Specification:

For each configuration, if it is a solution to the N queens problem, print YES in a line; or NO if not.

Sample Input:

4
8 4 6 8 2 7 1 3 5
9 4 6 7 2 8 1 9 5 3
6 1 5 2 6 4 3
5 1 3 5 2 4

Sample Output:

YES
NO
NO
YES

题⽬⼤意:

给出⼀个皇后图,以这样的⽅式给出:⼀个数组包含n个数字,每个数字表示该列的皇后所
在的⾏数,判断给出的皇后图是否满⾜不会互相攻击(任意两个皇后都要不在同⼀⾏或者同⼀列,且
不在斜对⻆线上)

分析:

⽤chess[n]存储⼀张图给出的数字,对于第j个数字,判断前0~j-1个数字中是否有在同⼀⾏的(v[j] 等于 v[t])和在斜对⻆线上的(abs(v[j]-v[t]) 等于 abs(j-t))【因为由题目可知所有皇后不在同⼀列了,所以不需要
判断是否在同⼀列】如果发现了不满⾜的情况,就将flag由true标记为false,最后根据flag是true还是false输出对应的YES还是NO
代码:[逻辑题]

//1128 N Queens Puzzle (20分)
#include <iostream>
#include <cmath>
#include <vector>
using namespace std;
int main() 
{
	int n;
	cin>>n;
	for(int i=0;i<n;i++)
	{
		int num;
		bool flag=true;
		cin>>num;
		vector<int> chess(num);
		for(int j=0;j<num;j++)
		{
			cin>>chess[j];
			for(int k=0;k<j;k++)
			{
				if(chess[j]==chess[k]||abs(chess[j]-chess[k])==abs(j-k))//chess[j]==chess[k]表示在同一行,abs(chess[j]-chess[k])==abs(j-k)表示在对角线上 
				{
					flag=false;
					break;
				}
			}
		}
		printf("%s\n",flag?"YES":"NO");
	}
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值