1095 Cars on Campus (30分)

13 篇文章 0 订阅

Zhejiang University has 8 campuses and a lot of gates. From each gate we can collect the in/out times and the plate numbers of the cars crossing the gate. Now with all the information available, you are supposed to tell, at any specific time point, the number of cars parking on campus, and at the end of the day find the cars that have parked for the longest time period.

Input Specification:
Each input file contains one test case. Each case starts with two positive integers N (≤10​4), the number of records, and K (≤8×104) the number of queries. Then N lines follow, each gives a record in the format:

plate_number hh:mm:ss status   

where plate_number is a string of 7 English capital letters or 1-digit numbers; hh:mm:ss represents the time point in a day by hour:minute:second, with the earliest time being 00:00:00 and the latest 23:59:59; and status is either in or out.

Note that all times will be within a single day. Each in record is paired with the chronologically next record for the same car provided it is an out record. Any in records that are not paired with an out record are ignored, as are out records not paired with an in record. It is guaranteed that at least one car is well paired in the input, and no car is both in and out at the same moment. Times are recorded using a 24-hour clock.

Then K lines of queries follow, each gives a time point in the format hh:mm:ss. Note: the queries are given in ascending order of the times.

Output Specification:

For each query, output in a line the total number of cars parking on campus. The last line of output is supposed to give the plate number of the car that has parked for the longest time period, and the corresponding time length. If such a car is not unique, then output all of their plate numbers in a line in alphabetical order, separated by a space.

Sample Input:

16 7
JH007BD 18:00:01 in
ZD00001 11:30:08 out
DB8888A 13:00:00 out
ZA3Q625 23:59:50 out
ZA133CH 10:23:00 in
ZD00001 04:09:59 in
JH007BD 05:09:59 in
ZA3Q625 11:42:01 out
JH007BD 05:10:33 in
ZA3Q625 06:30:50 in
JH007BD 12:23:42 out
ZA3Q625 23:55:00 in
JH007BD 12:24:23 out
ZA133CH 17:11:22 out
JH007BD 18:07:01 out
DB8888A 06:30:50 in
05:10:00
06:30:50
11:00:00
12:23:42
14:00:00
18:00:00
23:59:00

Sample Output:

1
4
5
2
1
0
1
JH007BD ZD00001 07:20:09

题⽬⼤意:

给出n个⻋牌号、时间点、进出状态的记录,然后查询k个时间点这时校园内的⻋辆个数。最后还要输出在校园⾥⾯呆的时间最⻓的⻋的⻋牌号,以及呆了多久的时间。如果有多辆⻋就按照它的字⺟从⼩到⼤输出⻋牌。配对要求是,如果⼀个⻋多次进⼊未出,取最后⼀个值;如果⼀个⻋多次out未进⼊,取第⼀个值。
注意:
⼀个⻋可能出⼊校园好多次,停⻋的时间应该取之和。

分析:

为了简便,应该把⼩时和分钟都化简成秒数计算⽐较⽅便。
⼀开始所有⻋辆的id、时间和是进还是出(进的flag是1,出的flag是-1),对他们排序,先按照⻋牌号排序,再按照来的时间先后排序。此后就能根据这样的排序后的顺序将所有满⾜条件(合法)的⻋辆进出记录保存到另⼀个数组⾥⾯。这个数组再按照时间先后排序。因为多次询问值,为了避免超时,可以把他们的⻋辆数cnt数组先算出来。到时候直接取值就会⽐较快速。cnt[i]表示在i下标的记录的时间点的时候⻋辆的数量。数量可以由前⼀个数量+当前⻋辆的flag得到。因为问询的时候是多个时间点按照从⼩到⼤的顺序,利⽤好这点能避免超时。如果上⼀个查询的index已经被记住,那么下⼀次就只需要从这个index开始找就可以了,避免重复寻找,浪费时间。
这道题目还是有一定难度的,参考了liuchuo的代码

//1095 Cars on Campus (30分)
#include<bits/stdc++.h>
using namespace std;
struct node
{
	char id[10];
	int time,flag;
};
bool cmp1(node n1,node n2)
{
	if(strcmp(n1.id,n2.id)!=0)
		return strcmp(n1.id,n2.id)<0;
	else
		return n1.time<n2.time;
}
bool cmp2(node n1,node n2)
{
	return n1.time<n2.time;
}
int main()
{
	int n,k,maxtime=-1;
	scanf("%d%d",&n,&k);
	vector<node> record(n),car;
	for(int i=0; i<n; i++)
	{
		int h,m,s,temptime;
		char statu[10];
		scanf("%s %d:%d:%d %s",record[i].id,&h,&m,&s,statu);
		temptime=h*60*60+m*60+s;
		record[i].time=temptime;
		record[i].flag=strcmp(statu,"in")==0?1:-1;//1表示in,-1表示out 
	}
	sort(record.begin(),record.end(),cmp1);//按id递增排序,id相同按时间递增排序 
	map<string,int> m;
	for(int i=0; i<n-1; i++)
	{
		if(strcmp(record[i].id,record[i+1].id)==0&&record[i].flag==1&&record[i+1].flag==-1)
		{
			car.push_back(record[i]);
			car.push_back(record[i+1]);
			m[record[i].id]+=record[i+1].time-record[i].time;//停车时间累加 
			if(maxtime<m[record[i].id])
				maxtime=m[record[i].id];//取最大停车时间 
		}
	}
	sort(car.begin(),car.end(),cmp2);//按时间排序,因为query时间是是递增 
	vector<int> cnt(n);
	for(int i=0; i<car.size(); i++)
	{
		if(i==0)
			cnt[i]+=car[i].flag;
		else
			cnt[i]=cnt[i-1]+car[i].flag;//前一时间停车数量加上当前时间的停车的数量 
	}
	int tempindex=0;
	for(int i=0; i<k; i++)
	{
		int h,m,s,temptime;
		scanf("%d:%d:%d",&h,&m,&s);
		temptime=h*3600+m*60+s;
		int j;
		for(j=tempindex; j<car.size(); j++)
		{
			if(car[j].time>temptime)
			{
				printf("%d\n",cnt[j-1]);
				break;
			}
			else if(j==car.size()-1)//last one 
				printf("%d\n",cnt[j]);
		}
		tempindex=j;
	}
	for(auto it=m.begin(); it!=m.end(); it++)
	{
		if(maxtime==it->second)
			printf("%s ",it->first.c_str());
	}
	printf("%02d:%02d:%02d\n", maxtime/3600, (maxtime%3600)/60,maxtime%60);
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值