1096 Consecutive Factors (20分)

Among all the factors of a positive integer N, there may exist several consecutive numbers. For example, 630 can be factored as 3×5×6×7, where 5, 6, and 7 are the three consecutive numbers. Now given any positive N, you are supposed to find the maximum number of consecutive factors, and list the smallest sequence of the consecutive factors.

Input Specification:

Each input file contains one test case, which gives the integer N (1<N<2​31
​​ ).

Output Specification:

For each test case, print in the first line the maximum number of consecutive factors. Then in the second line, print the smallest sequence of the consecutive factors in the format factor[1]factor[2]…*factor[k], where the factors are listed in increasing order, and 1 is NOT included.

Sample Input:

630

Sample Output:

3
5*6*7

题意

⼀个正整数N的因⼦中可能存在若⼲连续的数字。例如630可以分解为356*7,其中5、6、7就是3个连续的数字。给定任⼀正整数N,要求编写序求出最⻓连续因⼦的个数,并输出最⼩的连续因⼦序列。

分析

1,如果只有⼀个因⼦,那么这个数只能为1或者质数。因此我们主要去计算两个及以上因数的情况。
2,在有两个及以上的数连乘中,因数的最⼤上限为sqrt(N),即N的平⽅根。 3,因此思路就是,不断构造连乘,看连乘的积是否是N的因数,如果是,则看这部分连乘的数的个数是否⽐已记录的多。
4,⽤变量first记录连乘的第⼀个数字,这⾥我把它赋初值为0,如果在寻找N的因数过程中,first没有改变,那么就表明N是1或者是⼀个质数
一开始没写出来,参考了大神代码

//1096 Consecutive Factors (20分)
#include <iostream>
#include <cmath>
using namespace std;
int main()
{
	
	int num;
	cin>>num;
	int first=0,len=0,sqr=sqrt(num);
	for(int i=2;i<=sqr;i++)
	{
		int temp=1,j;
		for(j=i;j<=sqr;j++)
		{
			temp*=j;
			if(num%temp!=0)
				break;
		}
		if(j-i>len)
		{
			len=j-i;
			first=i;
		}
	}
	if(first==0)
		cout<<1<<endl<<num<<endl;
	else
	{
		cout<<len<<endl;
		for(int i=0;i<len;i++)
		{
			if(i==0)
				cout<<first;
			else
				cout<<"*"<<first+i;
		}
	}
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值