1078 Hashing (25分)

2 篇文章 0 订阅

The task of this problem is simple: insert a sequence of distinct positive integers into a hash table, and output the positions of the input numbers. The hash function is defined to be H(key)=key%TSize where TSize is the maximum size of the hash table. Quadratic probing (with positive increments only) is used to solve the collisions.

Note that the table size is better to be prime. If the maximum size given by the user is not prime, you must re-define the table size to be the smallest prime number which is larger than the size given by the user.

Input Specification:

Each input file contains one test case. For each case, the first line contains two positive numbers: MSize (≤104) and N (≤MSize) which are the user-defined table size and the number of input numbers, respectively. Then N distinct positive integers are given in the next line. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print the corresponding positions (index starts from 0) of the input numbers in one line. All the numbers in a line are separated by a space, and there must be no extra space at the end of the line. In case it is impossible to insert the number, print “-” instead.

Sample Input:

4 4
10 6 4 15

Sample Output:

0 1 4 -

题⽬⼤意:

给出散列表⻓和要插⼊的元素,将这些元素按照读⼊的顺序插⼊散列表中,其中散列函数为h(key) = key % TSize,解决冲突采⽤只向正向增加的⼆次⽅探查法。如果题中给出的TSize不是素数,就取第⼀个⽐TSize⼤的素数作为TSize
注意 是(key + step *step) % size ⽽不是(key % size + step * step)
刚开始没注意这句话,没有用步数的2次作为增量处理碰撞
Quadratic probing (with positive increments only) is used to solve the collisions.

//1078 Hashing (25分)
#include<iostream>
using namespace std;
int hashTable[10005];
bool isPrime(int x)
{
	if(x==0||x==1)
		return false;
	for(int i=2; i*i<=x; i++)
	{
		if(x%i==0)
			return false;
	}
	return true;
}
int main()
{
	int m,n;
	cin>>m>>n;
	while(!isPrime(m))
		m++;
	for(int i=0; i<n; i++)
	{
		int v;
		cin>>v;
		if(i!=0)
			cout<<" ";
		int j;
		for(j=0; j<m; j++)
		{
			int index=(v+j*j)%m;
			if(hashTable[index]==0)
			{
				hashTable[index]=1;
				cout<<index;
				break;
			}
		}
		if(j==m)
			cout<<"-";
	}
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值