1145 Hashing - Average Search Time (25分)

2 篇文章 0 订阅

The task of this problem is simple: insert a sequence of distinct positive integers into a hash table first. Then try to find another sequence of integer keys from the table and output the average search time (the number of comparisons made to find whether or not the key is in the table). The hash function is defined to be H(key)=key%TSize where TSize is the maximum size of the hash table. Quadratic probing (with positive increments only) is used to solve the collisions.

Note that the table size is better to be prime. If the maximum size given by the user is not prime, you must re-define the table size to be the smallest prime number which is larger than the size given by the user.

Input Specification:

Each input file contains one test case. For each case, the first line contains 3 positive numbers: MSize, N, and M, which are the user-defined table size, the number of input numbers, and the number of keys to be found, respectively. All the three numbers are no more than 10​4. Then N distinct positive integers are given in the next line, followed by M positive integer keys in the next line. All the numbers in a line are separated by a space and are no more than 10​5​​ .

Output Specification:

For each test case, in case it is impossible to insert some number, print in a line X cannot be inserted. where X is the input number. Finally print in a line the average search time for all the M keys, accurate up to 1 decimal place.

Sample Input:

4 5 4
10 6 4 15 11
11 4 15 2

题⽬⼤意:

给定⼀个序列,⽤平⽅探测法解决哈希冲突,然后给出m个数字,如果这个数字不能够被插⼊就输出”X cannot be inserted.”,然后输出这m个数字的平均查找时间

如果hashTable[v]处正是v则查找到了,则退出循环,如果hashTable[v]处不存在数字表示没查找到,那么也要退出循环。每次查找的时候,退出循环之前的j就是这个数字的查找⻓度。最后cnt除以m得到平均查找时间然后输出

Sample Output:

15 cannot be inserted.
2.8
//1145 Hashing - Average Search Time (25分)
#include <iostream>
using namespace std;
int hashTable[10005];
bool isPrime(int x)
{
	if(x==0||x==1)
		return false;
	for(int i=2; i*i<=x; i++)
	{
		if(x%i==0)
			return false;
	}
	return true;
}
int main()
{
	int m,n,q;
	cin>>m>>n>>q;
	while(!isPrime(m))
		m++;
	for(int i=0; i<n; i++)
	{
		int v;
		cin>>v;
		int j;
		for(j=0; j<m; j++)
		{
			int index=(v+j*j)%m;
			if(hashTable[index]==0)
			{
				hashTable[index]=v;
				break;
			}
		}
		if(j==m)
			cout<<v<<" cannot be inserted."<<endl;
	}
	int cnt=0;
	for(int i=0; i<q; i++)
	{
		int query;
		cin>>query;
		for(int j=0; j<=m; j++)
		{
			int index=(query+j*j)%m;
			cnt++;
			if(hashTable[index]==query||hashTable[index]==0)//如果找到了退出循环,如果当前位置没有说明没有插入也要退出循环
			{
				break;
			}
		}
	}
	printf("%.1f\n",(cnt*1.0/q));
	return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值