J - Invitation Cards

待更新..........

题目:

In the age of television, not many people attend theater performances. Antique Comedians of Malidinesia are aware of this fact. They want to propagate theater and, most of all, Antique Comedies. They have printed invitation cards with all the necessary information and with the programme. A lot of students were hired to distribute these invitations among the people. Each student volunteer has assigned exactly one bus stop and he or she stays there the whole day and gives invitation to people travelling by bus. A special course was taken where students learned how to influence people and what is the difference between influencing and robbery.

The transport system is very special: all lines are unidirectional and connect exactly two stops. Buses leave the originating stop with passangers each half an hour. After reaching the destination stop they return empty to the originating stop, where they wait until the next full half an hour, e.g. X:00 or X:30, where 'X' denotes the hour. The fee for transport between two stops is given by special tables and is payable on the spot. The lines are planned in such a way, that each round trip (i.e. a journey starting and finishing at the same stop) passes through a Central Checkpoint Stop (CCS) where each passenger has to pass a thorough check including body scan.

All the ACM student members leave the CCS each morning. Each volunteer is to move to one predetermined stop to invite passengers. There are as many volunteers as stops. At the end of the day, all students travel back to CCS. You are to write a computer program that helps ACM to minimize the amount of money to pay every day for the transport of their employees.

Input

The input consists of N cases. The first line of the input contains only positive integer N. Then follow the cases. Each case begins with a line containing exactly two integers P and Q, 1 <= P,Q <= 1000000. P is the number of stops including CCS and Q the number of bus lines. Then there are Q lines, each describing one bus line. Each of the lines contains exactly three numbers - the originating stop, the destination stop and the price. The CCS is designated by number 1. Prices are positive integers the sum of which is smaller than 1000000000. You can also assume it is always possible to get from any stop to any other stop.

Output

For each case, print one line containing the minimum amount of money to be paid each day by ACM for the travel costs of its volunteers.

Sample Input

2
2 2
1 2 13
2 1 33
4 6
1 2 10
2 1 60
1 3 20
3 4 10
2 4 5
4 1 50

Sample Output

46
210

 

推荐博客:https://www.cnblogs.com/liuxin13/p/4656746.html

 

 

#include<stdio.h>
#include<string.h>
#include<algorithm>
#include<stdlib.h>
#include<math.h>
#include<queue>
#define N 1000000
#define INF 0x03ffffffffffffff;
using namespace std;
struct node{
    int u,v,w,next;
}e[N+10];
int head[N+10],book[N+10];
long long dis[N+10],sum[N+10];//book表示该顶点有没有进入队列
void Add(int u,int v,int w,int k)//将特征元素为u的连接到一条链上,并且将对应结构体数据改为从u松弛的
{
    e[k].u=u;
    e[k].v=v;
    e[k].w=w;
    e[k].next=head[u];
    head[u]=k;
}
void spfa_quick()
{
    int u,k;//u松弛  k实现链表
    long long mid;
    queue<int>mmp;
    mmp.push(1);//将松弛点加入队列
    book[1]=1;
    while(!mmp.empty())
    {
        u=mmp.front();
        k=head[u];
        while(k!=-1)//遍历链上的数据//k为此时链上的下标
        {
            mid=dis[e[k].u]+e[k].w;
            if(mid<dis[e[k].v])
            {
                dis[e[k].v]=mid;
                if(!book[e[k].v])
                {
                    mmp.push(e[k].v);
                    book[e[k].v]=1;
                }
            }
            k=e[k].next;
        }
        mmp.pop();
        book[u]=0;
    }
}
int main()
{
    int t,n,m,u,v,w;
    long long ans;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d %d",&n,&m);
        for(int i=1;i<=n;i++)//
            head[i]=-1;
        for(int i=1;i<=m;i++)
        {
            scanf("%d %d %d",&u,&v,&w);
            Add(u,v,w,i);
        }
        for(int i=1;i<=n;i++)
        {
            dis[i]=INF;
            book[i]=0;
        }
        dis[1]=0;
        spfa_quick();
        for(int i=1;i<=n;i++)//存下去的路径 初始化head  初始化DIS
        {
//            printf("1->i dis[%d]=%d\n",i,dis[i]);
            sum[i]=dis[i];
            dis[i]=INF;
            head[i]=-1;
        }
        dis[1]=0;
        for(int i=1;i<=m;i++)//填上表
            Add(e[i].v,e[i].u,e[i].w,i);
//        printf("atter.....\n");
        spfa_quick();
        for(int i=1;i<=n;i++)//此时就计算好总路径1到i的来回路径最小和
        {
//            printf("i->1  dis[%d]=%d\n",i,dis[i]);
             sum[i]+=dis[i];
        }
        ans=0;
        for(int i=2;i<=n;i++)
            ans+=sum[i];
        printf("%lld\n",ans);
    }
}

 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
Wedding invitation H5是一种免费的电子邀请函平台,可以用来制作婚礼邀请函。H5是指使用HTML5技术,可以在浏览器中直接运行的网页。 Wedding invitation H5提供了各种模板供用户选择,用户只需根据自己的需求修改文字内容、配图等,即可制作出个性化的婚礼邀请函。 Wedding invitation H5的免费性质使其成为了许多新人的首选。相对于传统的印刷邀请函,H5邀请函具有许多优点。首先,H5邀请函制作和分发的成本较低,省去了印刷和邮寄的费用。其次,H5邀请函的传递速度更快,可以通过电子邮件、微信、朋友圈等方式一键分享给亲朋好友。此外,H5邀请函还支持更多的互动功能,如音乐、短视频、交互式地图等,能够为婚礼增添更多的亮点。 使用Wedding invitation H5制作婚礼邀请函非常简便。用户只需打开平台,选择心仪的模板,根据平台提供的编辑工具修改相关内容,如添加婚礼日期、地点、时间等。用户还可以上传自己的照片、视频以及音乐,使邀请函更加个性化。完成编辑后,用户可以预览效果,确认无误后即可保存和分享。Wedding invitation H5还提供了二维码下载和打印邀请函的选项,方便那些更喜欢传统方式的亲友。 总之,Wedding invitation H5的免费提供给了新人制作个性化、高效传达的婚礼邀请函的机会,并且使用简单方便。它在传统邀请函的基础上融入了现代科技,更加贴合了年轻人的需求。如果你正在准备婚礼并需要制作邀请函,Wedding invitation H5是一个不错的选择。

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值