Invitation Cards (POJ-2240)

Invitation Cards (POJ-2240)

Arbitrage is the use of discrepancies in currency exchange rates to transform one unit of a currency into more than one unit of the same currency. For example, suppose that 1 US Dollar buys 0.5 British pound, 1 British pound buys 10.0 French francs, and 1 French franc buys 0.21 US dollar. Then, by converting currencies, a clever trader can start with 1 US dollar and buy 0.5 * 10.0 * 0.21 = 1.05 US dollars, making a profit of 5 percent. 

Your job is to write a program that takes a list of currency exchange rates as input and then determines whether arbitrage is possible or not. 

Input

The input will contain one or more test cases. Om the first line of each test case there is an integer n (1<=n<=30), representing the number of different currencies. The next n lines each contain the name of one currency. Within a name no spaces will appear. The next line contains one integer m, representing the length of the table to follow. The last m lines each contain the name ci of a source currency, a real number rij which represents the exchange rate from ci to cj and a name cj of the destination currency. Exchanges which do not appear in the table are impossible. 
Test cases are separated from each other by a blank line. Input is terminated by a value of zero (0) for n.

Output

For each test case, print one line telling whether arbitrage is possible or not in the format "Case case: Yes" respectively "Case case: No".

Sample Input

3
USDollar
BritishPound
FrenchFranc
3
USDollar 0.5 BritishPound
BritishPound 10.0 FrenchFranc
FrenchFranc 0.21 USDollar

3
USDollar
BritishPound
FrenchFranc
6
USDollar 0.5 BritishPound
USDollar 4.9 FrenchFranc
BritishPound 10.0 FrenchFranc
BritishPound 1.99 USDollar
FrenchFranc 0.09 BritishPound
FrenchFranc 0.19 USDollar

0

Sample Output

Case 1: Yes
Case 2: No

题目翻译:

套利是利用货币汇率的差异,将一种货币的一个单位转换成同一货币的多个单位。例如,假设1美元买0.5英镑,1英镑买10.0法国法郎,1法国法郎买0.21美元。然后,通过兑换货币,聪明的交易者可以从1美元开始购买0.5 * 10.0 * 0.21 = 1.05美元,获利5%。

您的工作是编写一个程序,该程序将货币汇率列表作为输入,然后确定是否存在套利。

输入

输入将包含一个或多个测试用例。Om每个测试用例的第一行都有一个整数n (1<=n<=30),表示不同货币的数量。接下来的n行各包含一种货币的名称。在名称中不会出现空格。下一行包含一个整数m,表示要跟随的表的长度。最后m行分别包含源货币的名称ci、表示从ci到cj的汇率的实数rij和目标货币的名称cj。没有出现在表中的交换是不可能的。

测试用例之间用空行隔开。输入被n的0(0)值终止。

输出

对于每个测试用例,打印一行,分别以“case case: Yes”和“case case: No”格式表示是否可能进行套利。

思路:题目的思路就是看看能不能通过交换货币(货币互换存在利率),使你的钱得到增加。

这里给的顶点时货币的英文名,为了方便简洁,用map 将货币名 与 编号一一对应。

此题有多种解法,注意到顶点最大为30,可用Floyd算法求出整个图的最短路,注意此处并不是真正的最短路,但通过插点,即 i -> j 能否改成 i -> k -> j 的路,就会把环给考虑至少一次,那么对应的 path[i][i] 也就是本金肯定是增加的(相对于初值),为了方便,将本金设为 1 。

AC代码:

#include <stdio.h>
#include <algorithm>
#include <iostream>
#include <math.h>
#include <string.h>
#include <map>
#define inf 0x3f3f3f3f
#define MAX 1010
using namespace std;
int n,m;
double dp[MAX][MAX];
map<string,int>money;
void init()
{
    int i,j;
    for(i=0; i<n; i++)
        for(j=0; j<n; j++)
        {
            if(i==j)
                dp[i][j]=1;
            else
                dp[i][j]=0;
        }
}
int floyd()
{
    int i,j,k;
    for(k=0; k<n; k++)
        for(i=0; i<n; i++)
            for(j=0; j<n; j++)
            {
                if(dp[i][j]<dp[i][k]*dp[k][j])
                    dp[i][j]=dp[i][k]*dp[k][j];
            }
}
int main()
{
    string p,q;
    int cnt=1;
    double r;
    while(~scanf("%d",&n),n)
    {
        int i,j,k;
        init();
        for(i=0; i<n; i++)
        {
            cin>>p;
            money[p]=i;
        }
        scanf("%d",&m);
        for(i=0; i<m; i++)
        {
            cin>>p>>r>>q;
            dp[money[p]][money[q]]=r;
        }
        floyd();
        printf("Case %d: ",cnt++);
        for(i=0; i<n; i++)
        {
            if(dp[i][i]>1)
            {
                printf("Yes\n");
                break;
            }
            else if(i==n-1)
                printf("No\n");
        }
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值