Invitation Cards

Invitation Cards

Problem Description
In the age of television, not many people attend theater performances. Antique Comedians of Malidinesia are aware of this fact. They want to propagate theater and, most of all, Antique Comedies. They have printed invitation cards with all the necessary information and with the programme. A lot of students were hired to distribute these invitations among the people. Each student volunteer has assigned exactly one bus stop and he or she stays there the whole day and gives invitation to people travelling by bus. A special course was taken where students learned how to influence people and what is the difference between influencing and robbery. 
The transport system is very special: all lines are unidirectional and connect exactly two stops. Buses leave the originating stop with passangers each half an hour. After reaching the destination stop they return empty to the originating stop, where they wait until the next full half an hour, e.g. X:00 or X:30, where 'X' denotes the hour. The fee for transport between two stops is given by special tables and is payable on the spot. The lines are planned in such a way, that each round trip (i.e. a journey starting and finishing at the same stop) passes through a Central Checkpoint Stop (CCS) where each passenger has to pass a thorough check including body scan. 

All the ACM student members leave the CCS each morning. Each volunteer is to move to one predetermined stop to invite passengers. There are as many volunteers as stops. At the end of the day, all students travel back to CCS. You are to write a computer program that helps ACM to minimize the amount of money to pay every day for the transport of their employees. 

 

Input
The input consists of N cases. The first line of the input contains only positive integer N. Then follow the cases. Each case begins with a line containing exactly two integers P and Q, 1 <= P,Q <= 1000000. P is the number of stops including CCS and Q the number of bus lines. Then there are Q lines, each describing one bus line. Each of the lines contains exactly three numbers - the originating stop, the destination stop and the price. The CCS is designated by number 1. Prices are positive integers the sum of which is smaller than 1000000000. You can also assume it is always possible to get from any stop to any other stop. 
 

Output
For each case, print one line containing the minimum amount of money to be paid each day by ACM for the travel costs of its volunteers. 
 

Sample Input
  
  
2 2 2 1 2 13 2 1 33 4 6 1 2 10 2 1 60 1 3 20 3 4 10 2 4 5 4 1 50
 
Sample Output
   
   
46 210
 

题意解析:普通的最短路,只是建图的时候要正反两个方向进行建图。最近在学习最短路,所以就把优先队列优化的Dijkstra和Spfa都写了一遍。本来不准备写该篇博客的,但是由于该题的程序实在太吸引人了,所以手一动就。。。
 
    一个这么好的题的代码,怎么经过我的手就变得如此难看呢难过
 
     之后再分享一下个人经过练习发现的一个入门时可能会遇到的困惑吧。下面的Dijkstra STL的优化和Spfa的算法看上去似乎一个摸样。其实不然,当你仔细思考后会发现,spfa是可以用来计算有环存在的图的,所以该算法是允许一个节点可以多次进入队列的,而Dijkstra则不行,因为其只需要松弛n-1次。下面红色字体就代表两个算法不同的本质所在。
 
 
Dijkstra优先队列优化
#include <iostream>
#include <queue>
#include <cstring>
#include <cstdio>
using namespace std;

typedef pair<int,int> pii;

const int VN = 1e6 + 10;
const int EN = VN;
const int INF = 0x7fffffff >> 1;

struct Edge{int v,next,w;}E[EN];
priority_queue<pii,vector<pii>,greater<pii> >q;

int n,size;
int head[VN];
int d[VN];
int u[VN],v[VN],w[VN];

void Init(){
    size = 0;
    memset(head,-1,sizeof(head));
    while(!q.empty()) q.pop();
}
void AddEdge(int u,int v,int w){
    E[size].v = v,E[size].w = w;
    E[size].next = head[u];
    head[u] = size++;
}
void Dijkstra(int src){
    for(int i = 0;i <= n;i++)
      d[i] = i == 1 ? 0:INF;
    q.push(make_pair(d[src],src));
    while(!q.empty()){
        pii x = q.top(); q.pop();
        int u = x.second;
        if(x.first != d[u]) continue;
        for(int e = head[u];e != -1;e = E[e].next){
          int tmp =  d[u] + E[e].w;
          if(d[E[e].v] > tmp){
             d[E[e].v] = tmp;
             q.push(make_pair(tmp,E[e].v));
          }
        }
    }
}

int main()
{
    int T,m;
    scanf("%d",&T);
    while(T--){
        scanf("%d%d",&n,&m);
        Init();
        for(int i = 0;i < m;i++){
            scanf("%d%d%d",&u[i],&v[i],&w[i]);
            AddEdge(u[i],v[i],w[i]);
        }
        Dijkstra(1);
        __int64 sum = 0;
        for(int i = 1;i <= n;i++) sum += d[i];
        Init();
        for(int i = 0;i < m;i++)  //反向建图
          AddEdge(v[i],u[i],w[i]);
        Dijkstra(1);
        for(int i = 1;i <= n;i++) sum += d[i];
        printf("%I64d\n",sum);
    }
    return 0;
}



Spfa算法
 
 
 
#include <iostream>
#include <queue>
#include <cstdio>
#include <cstring>
using namespace std;

const int EN = 1e6 + 10;
const int VN = EN;
const int INF = 0x7fffffff >> 1;
struct Edge
{
   int v,next,w;
}E[EN];

int n,size;
int head[VN];
int d[VN];
int u[VN],v[VN],cost[VN];

void Init()
{
    fill(head,head+n,-1);
    size = 0;
}
void AddEdge(int u,int v,int w)
{
    E[size].v = v,E[size].w = w;
    E[size].next = head[u];
    head[u] = size++;
}
void Spfa()
{
    for(int i = 0;i <= n;i++)
      d[i] = i == 1? 0 : INF;
    bool inq[VN];
    memset(inq,0,sizeof(inq));
    queue<int> q;
    q.push(1);
    while(!q.empty())
    {
        int u = q.front();
        q.pop();
        inq[u] = 0;    //注意此处是区别所在
        for(int e = head[u];e != -1;e = E[e].next)
          if(d[u] + E[e].w < d[E[e].v]){
              d[E[e].v] = d[u] + E[e].w;
              if(!inq[E[e].v]){
                inq[E[e].v] = 1;  //注意
                q.push(E[e].v);
              }
          }
    }
}
int main()
{
    int T,m;
    scanf("%d",&T);
    while(T--)
    {
        scanf("%d%d",&n,&m);
        Init();
        for(int i = 0;i < m;i++){
            scanf("%d%d%d",&u[i],&v[i],&cost[i]);
            AddEdge(u[i],v[i],cost[i]);
        }
        Spfa();
        __int64 sum = 0;
        for(int i = 1;i <= n;i++) sum += d[i];
        Init();
        for(int i = 0;i < m;i++)
          AddEdge(v[i],u[i],cost[i]);
        Spfa();
        for(int i = 1;i <= n;i++) sum += d[i];
        printf("%I64d\n",sum);
    }
    return 0;
}




Wedding invitation H5是一种免费的电子邀请函平台,可以用来制作婚礼邀请函。H5是指使用HTML5技术,可以在浏览器中直接运行的网页。 Wedding invitation H5提供了各种模板供用户选择,用户只需根据自己的需求修改文字内容、配图等,即可制作出个性化的婚礼邀请函。 Wedding invitation H5的免费性质使其成为了许多新人的首选。相对于传统的印刷邀请函,H5邀请函具有许多优点。首先,H5邀请函制作和分发的成本较低,省去了印刷和邮寄的费用。其次,H5邀请函的传递速度更快,可以通过电子邮件、微信、朋友圈等方式一键分享给亲朋好友。此外,H5邀请函还支持更多的互动功能,如音乐、短视频、交互式地图等,能够为婚礼增添更多的亮点。 使用Wedding invitation H5制作婚礼邀请函非常简便。用户只需打开平台,选择心仪的模板,根据平台提供的编辑工具修改相关内容,如添加婚礼日期、地点、时间等。用户还可以上传自己的照片、视频以及音乐,使邀请函更加个性化。完成编辑后,用户可以预览效果,确认无误后即可保存和分享。Wedding invitation H5还提供了二维码下载和打印邀请函的选项,方便那些更喜欢传统方式的亲友。 总之,Wedding invitation H5的免费提供给了新人制作个性化、高效传达的婚礼邀请函的机会,并且使用简单方便。它在传统邀请函的基础上融入了现代科技,更加贴合了年轻人的需求。如果你正在准备婚礼并需要制作邀请函,Wedding invitation H5是一个不错的选择。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值