POJ 3984 迷宫问题

迷宫问题
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 30044 Accepted: 17268

Description

定义一个二维数组: 
int maze[5][5] = {

	0, 1, 0, 0, 0,

	0, 1, 0, 1, 0,

	0, 0, 0, 0, 0,

	0, 1, 1, 1, 0,

	0, 0, 0, 1, 0,

};

它表示一个迷宫,其中的1表示墙壁,0表示可以走的路,只能横着走或竖着走,不能斜着走,要求编程序找出从左上角到右下角的最短路线。

Input

一个5 × 5的二维数组,表示一个迷宫。数据保证有唯一解。

Output

左上角到右下角的最短路径,格式如样例所示。

Sample Input

0 1 0 0 0
0 1 0 1 0
0 0 0 0 0
0 1 1 1 0
0 0 0 1 0

Sample Output

(0, 0)
(1, 0)
(2, 0)
(2, 1)
(2, 2)
(2, 3)
(2, 4)
(3, 4)
(4, 4)

题中是让找最短路径,用深搜的话只是可以找出是否存在路径,所以我们就用广搜来做,这道题跟我们平常做的题有些不同的是,这道题需要求得是具体路径,但是我们可以用一个father数组标记该节点的父结点,因为先搜索到这的点一定是会比后来搜索过来的点的路径要短,所以该点的父结点就唯一确认了

#include<stdio.h>
#include<string.h> 
#include<queue>
using namespace std;
int map[7][7];//记录图
int dir[4][2]={{1,0},{-1,0},{0,1},{0,-1}};//方向 
struct Node{
	int x,y;
}; 
Node father[7][7];//存储节点在遍历过程中的父结点 
void printf_result(){
	//因为需要按顺序输出,而我们现在只能从结尾逆向找回去,所以应该是还需要一个数组存储路径
	Node path[50];
	int count=0;//存储一下从终点到起点一共需要走多少步
	path[count].x=5;
	path[count].y=5;
	while(1){
		if(path[count].x==1&&path[count].y==1)
		break;
		path[count+1]=father[path[count].x][path[count].y];
		count++;
	} 
	while(count>=0){
		printf("(%d, %d)\n",path[count].x-1,path[count].y-1);
		count--;
	}
}
void bfs(){
	queue<Node>q;
	Node start;
	start.x=1;
	start.y=1;
	q.push(start);
	while(!q.empty()){
		Node s=q.front();
		q.pop();
		if(s.x==5&&s.y==5){
			printf_result();
			return ;
		}
		for(int i=0;i<4;i++){
			Node s2;
			s2.x=s.x+dir[i][0];
			s2.y=s.y+dir[i][1];
			if(map[s2.x][s2.y]==0){
				map[s2.x][s2.y]=1;
				father[s2.x][s2.y]=s;
				q.push(s2);
			} 
		}
	}
} 
int main(){
	memset(map,0,sizeof(map));
	for(int i=0;i<7;i++){//直接标记边界可以避免后续判断,也可以不这样后边判断边界 
		map[0][i]=1;
		map[i][0]=1;
		map[6][i]=1;
		map[i][6]=1;
	}
	for(int i=1;i<=5;i++){//赋值 
		for(int j=1;j<=5;j++){
			scanf("%d",&map[i][j]);
		}
	} 
	bfs();
	return 0;
} 

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
根据提供的引用内容,可以得知这是一道关于迷宫问题的题目,需要使用Java语言进行编写。具体来说,这道题目需要实现一个迷宫的搜索算法,找到从起点到终点的最路径。可以使用广度优先搜索或者深度优先搜索算法来决这个问题。 下面是一个使用广度优先搜索算法的Java代码示例: ```java import java.util.*; public class Main { static int[][] maze = new int[5][5]; // 迷宫地图 static int[][] dir = {{0, 1}, {0, -1}, {1, 0}, {-1, 0}}; // 方向数组 static boolean[][] vis = new boolean[5][5]; // 标记数组 static int[][] pre = new int[5][5]; // 记录路径 public static void main(String[] args) { Scanner sc = new Scanner(System.in); for (int i = 0; i < 5; i++) { for (int j = 0; j < 5; j++) { maze[i][j] = sc.nextInt(); } } bfs(0, 0); Stack<Integer> stack = new Stack<>(); int x = 4, y = 4; while (x != 0 || y != 0) { stack.push(x * 5 + y); int t = pre[x][y]; x = t / 5; y = t % 5; } stack.push(0); while (!stack.empty()) { System.out.print(stack.pop() + " "); } } static void bfs(int x, int y) { Queue<Integer> qx = new LinkedList<>(); Queue<Integer> qy = new LinkedList<>(); qx.offer(x); qy.offer(y); vis[x][y] = true; while (!qx.isEmpty()) { int tx = qx.poll(); int ty = qy.poll(); if (tx == 4 && ty == 4) { return; } for (int i = 0; i < 4; i++) { int nx = tx + dir[i][0]; int ny = ty + dir[i][1]; if (nx >= 0 && nx < 5 && ny >= 0 && ny < 5 && maze[nx][ny] == 0 && !vis[nx][ny]) { vis[nx][ny] = true; pre[nx][ny] = tx * 5 + ty; qx.offer(nx); qy.offer(ny); } } } } } ``` 该代码使用了广度优先搜索算法,首先读入迷宫地图,然后从起点开始进行搜索,直到找到终点为止。在搜索的过程中,使用标记数组记录已经访问过的位置,使用路径数组记录路径。最后,使用栈来输出路径。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值