PAT - 1034 Head of a Gang (30 分) 图的DFS

35 篇文章 0 订阅
29 篇文章 0 订阅

One way that the police finds the head of a gang is to check people's phone calls. If there is a phone call between A and B, we say that A and B is related. The weight of a relation is defined to be the total time length of all the phone calls made between the two persons. A "Gang" is a cluster of more than 2 persons who are related to each other with total relation weight being greater than a given threshold K. In each gang, the one with maximum total weight is the head. Now given a list of phone calls, you are supposed to find the gangs and the heads.

Input Specification:

Each input file contains one test case. For each case, the first line contains two positive numbers N and K (both less than or equal to 1000), the number of phone calls and the weight threthold, respectively. Then N lines follow, each in the following format:

Name1 Name2 Time

where Name1 and Name2 are the names of people at the two ends of the call, and Time is the length of the call. A name is a string of three capital letters chosen from A-Z. A time length is a positive integer which is no more than 1000 minutes.

Output Specification:

For each test case, first print in a line the total number of gangs. Then for each gang, print in a line the name of the head and the total number of the members. It is guaranteed that the head is unique for each gang. The output must be sorted according to the alphabetical order of the names of the heads.

Sample Input 1:

8 59
AAA BBB 10
BBB AAA 20
AAA CCC 40
DDD EEE 5
EEE DDD 70
FFF GGG 30
GGG HHH 20
HHH FFF 10

Sample Output 1:

2
AAA 3
GGG 3

Sample Input 2:

8 70
AAA BBB 10
BBB AAA 20
AAA CCC 40
DDD EEE 5
EEE DDD 70
FFF GGG 30
GGG HHH 20
HHH FFF 10

Sample Output 2:

0

作者: CHEN, Yue

单位: 浙江大学

时间限制: 400 ms

内存限制: 64 MB

#include<iostream>
#include<string>
#include<map>
using namespace std;
const int maxn = 2010;
const int INF = 1E9;

map<int, string> intToString;
map<string, int> stringToInt;
map<string, int> Gang; // head and number

int G[maxn][maxn] = {0}, weight[maxn] = {0};
int n, k, numPerson = 0;
bool vis[maxn] = {false};

void DFS(int nowVisit, int& head, int& numMember, int& totalValue){
    numMember++;
    vis[nowVisit] = true;
    if(weight[nowVisit] > weight[head])
      {  head = nowVisit;}
    for(int i = 0; i < numPerson; i++){//扫描每条边,发现,则进入
        if(G[nowVisit][i] > 0){
            totalValue += G[nowVisit][i]; // edge weight
            G[nowVisit][i] = G[i][nowVisit] = 0;
            if(vis[i] == false)
                DFS(i, head, numMember, totalValue);
        }
    }
}


void DFSTrave(){
    for(int u = 0; u < numPerson; u++){
        if(vis[u]==false){
            int head = u, numMember = 0, totalValue = 0;
            DFS(u, head, numMember, totalValue);
            if(numMember > 2 && totalValue > k){
                Gang[intToString[head]] = numMember;
            }
        }
          
    }
}

int change(string str){
    if(stringToInt.find(str) != stringToInt.end()){//已经出现过
        return stringToInt[str];
    }
    else{  
        stringToInt[str] = numPerson;
        intToString[numPerson] = str;
        return numPerson++;
    }
  
}
int main(){
    string string1,string2;
    int w;
    cin>>n>>k;
    for(int i = 0 ;i < n; i++){
        cin>>string1>>string2>>w;
        int id1 = change(string1);
        int id2 = change(string2);
        weight[id1] += w;
        weight[id2] += w;
        G[id1][id2] += w;
        G[id2][id1] += w;
    }
    //找到头目及总权值
    DFSTrave();
    cout<<Gang.size()<<endl;
    map<string, int>::iterator it;
    for(it = Gang.begin(); it != Gang.end(); it++){
        cout<<it->first<<" "<<it->second<<endl;
    }
    return 0;
}

图的问题,比较难搞。

  1. stringToInt,将人名转换成整数,然后存储到邻接矩阵中,整数可以直接采用【总人数】进行计数。
  2. 存储好点的权值和边的权值,还有一个连通分量中的总权值,在DFS中对这些变量进行更新。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值