PAT甲级 - 1102 Invert a Binary Tree (25 分) 反转二叉树

40 篇文章 0 订阅
35 篇文章 0 订阅

 

The following is from Max Howell @twitter:

Google: 90% of our engineers use the software you wrote (Homebrew), but you can't invert a binary tree on a whiteboard so fuck off.

Now it's your turn to prove that YOU CAN invert a binary tree!

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤10) which is the total number of nodes in the tree -- and hence the nodes are numbered from 0 to N−1. Then N lines follow, each corresponds to a node from 0 to N−1, and gives the indices of the left and right children of the node. If the child does not exist, a - will be put at the position. Any pair of children are separated by a space.

Output Specification:

For each test case, print in the first line the level-order, and then in the second line the in-order traversal sequences of the inverted tree. There must be exactly one space between any adjacent numbers, and no extra space at the end of the line.

Sample Input:

8
1 -
- -
0 -
2 7
- -
- -
5 -
4 6

Sample Output:

3 7 2 6 4 0 5 1
6 5 7 4 3 2 0 1

这道题算是最近做的最简单的题了,只需要把输出的顺序调换一下即可。 

#include<cstdio>
#include<cstring>
#include<queue>
using namespace std;
const int maxn = 20;
int n;
struct node {
	int left, right;
	node(int _left = -1, int _right = -1) : left(_left), right(_right) {}
}Node[maxn];
int pre[maxn];

int FindRoot() {
	int i;
	for (i = 0; i < n; i++)
	{
		if (pre[i] == -1)
			break;
	}
	return i;
}

int num;

void LevelOrder(int root) {
	queue<int> q;
	q.push(root);
	while (!q.empty()) {
		int top = q.front();
		q.pop();
		printf("%d", top);
		num++;
		if (num < n)
			printf(" ");
		if (Node[top].right != -1) {
			q.push(Node[top].right);
		}
		if (Node[top].left != -1) {
			q.push(Node[top].left);
		}
		
	}
}


void InOrder(int root) {
	if (root == -1)
		return;
	InOrder(Node[root].right);
	printf("%d", root);
	num++;
	if (num < n)
		printf(" ");
	InOrder(Node[root].left);
}

int main() {
	memset(pre, -1, sizeof(pre));
	scanf("%d", &n);
	char lchild, rchild;
	for (int i = 0; i < n; i++) {
		getchar();
		lchild = getchar();
		getchar();
		rchild = getchar();
		if (lchild != '-') {
			Node[i].left = lchild - '0';
			pre[lchild - '0'] = i;
		}
		if (rchild != '-') {
			Node[i].right = rchild - '0';
			pre[rchild - '0'] = i;
		}
	}
	int root = FindRoot();
	num = 0;
	LevelOrder(root);
	printf("\n");
	num = 0;
	InOrder(root);
}

实际上,交换二叉树可以通过postorder完成,在访问根节点时swap。一层一层swap。 

对于根节点的判断,还可以通过notRoot数组。

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 1
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值