PAT甲级 - 1079 Total Sales of Supply Chain (25 分) 树+BFS

40 篇文章 0 订阅
35 篇文章 0 订阅

A supply chain is a network of retailers(零售商), distributors(经销商), and suppliers(供应商)-- everyone involved in moving a product from supplier to customer.

Starting from one root supplier, everyone on the chain buys products from one's supplier in a price P and sell or distribute them in a price that is r% higher than P. Only the retailers will face the customers. It is assumed that each member in the supply chain has exactly one supplier except the root supplier, and there is no supply cycle.

Now given a supply chain, you are supposed to tell the total sales from all the retailers.

Input Specification:

Each input file contains one test case. For each case, the first line contains three positive numbers: N (≤10​5​​), the total number of the members in the supply chain (and hence their ID's are numbered from 0 to N−1, and the root supplier's ID is 0); P, the unit price given by the root supplier; and r, the percentage rate of price increment for each distributor or retailer. Then N lines follow, each describes a distributor or retailer in the following format:

K​i​​ ID[1] ID[2] ... ID[K​i​​]

where in the i-th line, K​i​​ is the total number of distributors or retailers who receive products from supplier i, and is then followed by the ID's of these distributors or retailers. K​j​​ being 0 means that the j-th member is a retailer, then instead the total amount of the product will be given after K​j​​. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print in one line the total sales we can expect from all the retailers, accurate up to 1 decimal place. It is guaranteed that the number will not exceed 10​10​​.

Sample Input:

10 1.80 1.00
3 2 3 5
1 9
1 4
1 7
0 7
2 6 1
1 8
0 9
0 4
0 3

Sample Output:

42.4
  1. 使用BFS对层数进行标记,不知道算不算是自己首创的! 
  2. 树的结构定义,有layer,有vector<int> child,有number
  3. double数据类型的输入是%lf,输出是%f
#include<cstdio>
#include<vector>
#include<cmath>
#include<queue>
using namespace std;
const int maxn = 100010;
int n;
double p, r;
struct Node {
	int number;
	int layer;
	vector<int> child;
	Node(int _number = 0, int _layer = 0) :number(_number), layer(_layer) {}
}node[maxn];
bool is_retailer[maxn] = { false };

void BFS() { //BFS标记深度?
	int root = 0;
	int cur_num = 1; //标记当前层的节点数
	int next_num = 0; //下一层的节点数
	queue<int> q;
	q.push(root);
	int level = 0;
	node[root].layer = level;
	level++;
	while (!q.empty()) {
		int top = q.front();
		q.pop();
		for (int i = 0; i < node[top].child.size(); i++) {
			q.push(node[top].child[i]);
			node[node[top].child[i]].layer = level;
			next_num++;
		}
		cur_num--;
		if (cur_num == 0) //进入下一层
		{
			level++;
			cur_num = next_num;
			next_num = 0;
		}
	}
}

int main() {
	scanf("%d%lf%lf", &n, &p, &r);
	int childN, child;
	for (int i = 0; i < n; i++) {
		scanf("%d", &childN);
		for (int j = 0; j < childN; j++) {
			scanf("%d", &child);
			node[i].child.push_back(child);
		}
		if (childN == 0)
		{
			int sell_number;
			scanf("%d", &sell_number);
			node[i].number = sell_number;
			is_retailer[i] = true;
		}
	}
	BFS();
	double ans = 0;
	for (int i = 0; i < n; i++) {
		double tmp;  //注意结果是double!!!!!
		if (is_retailer[i]) {
			 tmp = double(node[i].number) * p * pow((1 + 0.01 * r), node[i].layer);
			 ans += tmp;
		}
	}
	printf("%.1f", ans);
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值