第十三周OJ项目c:统计元音字母个数

问题:

C: 统计元音字母个数

Description
统计每个元音字母在字符串中出现的次数。
Input
输入一行长度不超过100的字符串。
Output
输出各个元音字母出现的次数。
Sample Input
my name is ignatius
Sample Output
a:2
e:1
i:3
o:0
u:1


代码:

#include <iostream>
#include<cstdio>
using namespace std;

int main()
{
    int i=0;
    int num1=0,num2=0,num3=0,num4=0,num5=0;
    char a[100];                            //数组不超过100
    gets( a);
    while(a[i]!='\0')                       //直到字符串结束
    {
        if (a[i]=='A'||a[i]=='a')
            num1++;
        else if (a[i]=='E'||a[i]=='e')
            num2++;
        else if (a[i]=='I'||a[i]=='i')
            num3++;
        else if (a[i]=='O'||a[i]=='o')
            num4++;
        else if (a[i]=='U'||a[i]=='u')
            num5++;
        i++;
    }
    cout<<"a:"<<num1<<endl;
    cout<<"e:"<<num2<<endl;
    cout<<"i:"<<num3<<endl;
    cout<<"o:"<<num4<<endl;
    cout<<"u:"<<num5<<endl;


    return 0;
}

运行结果:


知识点总结:

字符串结束时为 /0

统计元音字母个数,利用switch语句


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值