POJ 2406 kmp求循环节个数

题目链接:

[kuangbin带你飞]专题十六 KMP & 扩展KMP & Manacher  G - Power
Strings

Description

Given two strings a and b we define a*b to be their concatenation. For
example, if a = “abc” and b = “def” then a*b = “abcdef”. If we think
of concatenation as multiplication, exponentiation by a non-negative
integer is defined in the normal way: a^0 = “” (the empty string) and
a^(n+1) = a*(a^n).

Input

Each test case is a line of input representing s, a string of
printable characters. The length of s will be at least 1 and will not
exceed 1 million characters. A line containing a period follows the
last test case.

Output

For each s you should print the largest n such that s = a^n for some
string a.

Sample Input

abcd
aaaa
ababab
.

Sample Output

1
4
3

/*************************************************************************
    > File Name: poj_2406.cpp
    > Author: dulun
    > Mail: dulun@xiyoulinux.org
    > Created Time: 2016年03月16日 星期三 13时19分57秒
 ************************************************************************/

#include<iostream>
#include<stdio.h>
#include<cstring>
#include<cstdlib>
#include<algorithm>
#define LL long long
using namespace std;

const int N = 1000086;
char a[N];
int nxt[N];

void getnxt()
{
    int m = strlen(a);
    int k = 0; 
    memset(nxt, 0, sizeof(nxt));

    for(int i = 1; i < m ; i++)
    {
        while(k&& a[k] != a[i]) k = nxt[k-1];
        if(a[k] == a[i]) k++;
        nxt[i] = k;
    }
}


int main()
{
    while(~scanf("%s", a) && a[0] != '.')
    {
        getnxt();
        int m = strlen(a);
        int t = m - nxt[m-1];
        if( m % t == 0)
            printf("%d\n", m / t);
        else
            printf("1\n");
        memset(a, 0, sizeof(0));
    }

    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值