sdnu-并查集-weeklyexam —— B - Pseudo-Random Numbers

Computers normally cannot generate really random numbers, but frequently are used to generate sequences of pseudo-random numbers. These are generated by some algorithm, but appear for all practical purposes to be really random. Random numbers are used in many applications, including simulation.
A common pseudo-random number generation technique is called the linear congruential method. If the last pseudo-random number generated was L, then the next number is generated by evaluating ( Z x L + I ) mod M, where Z is a constant multiplier, I is a constant increment, and M is a constant modulus. For example, suppose Z is 7, I is 5, and M is 12. If the first random number (usually called the seed) is 4, then we can determine the next few pseudo-random numbers are follows:




As you can see, the sequence of pseudo-random numbers generated by this technique repeats after six numbers. It should be clear that the longest sequence that can be generated using this technique is limited by the modulus, M.

In this problem you will be given sets of values for Z, I, M, and the seed, L. Each of these will have no more than four digits. For each such set of values you are to determine the length of the cycle of pseudo-random numbers that will be generated. But be careful: the cycle might not begin with the seed!
Input
Each input line will contain four integer values, in order, for Z, I, M, and L. The last line will contain four zeroes, and marks the end of the input data. L will be less than M.
Output
For each input line, display the case number (they are sequentially numbered, starting with 1) and the length of the sequence of pseudo-random numbers before the sequence is repeated.
Sample Input
7 5 12 4
5173 3849 3279 1511
9111 5309 6000 1234
1079 2136 9999 1237
0 0 0 0
Sample Output
Case 1: 6
Case 2: 546
Case 3: 500

Case 4: 220


这个题目坑人的地方告诉你了,就是不一定从第一个值开始循环,奈何英语不好,一开始wa了几次

剩余的还好说吧,随机数的公式已知了,根据那个公式把每一个生成的随机数连起来

一但发现——出现了某一个的随机数哒老大就是他自己,那么可以得到初步额循环节的大小

然后还得再开始一遍看看是不是一开始就进入了循环例如 4 9 8 1 0 5 9 8 1 0 5 9 8 1 0 5

开始的四就没有进入循环,判断第一个循环起始点前有几个数,最终结果就减去几就odk了

但是有一点要注意就是你初始化老大的时候不能弄成本身,我是弄成了-1,一个不会影响结果的值,然后相应的find函数也做出了改变

#include<iostream>
#include<fstream>
#include<cstring>
using namespace std;

long long Z,I,M,L;
int pre[100000];
int find(int x)
{
    return -1 == pre[x] ? x : find(pre[x]);
}
int main()
{
long long count = 0;
while(cin>>Z>>I>>M>>L)
{
	if(Z==0&&I==0&&M==0&&L==0)break;
	memset(pre,-1,sizeof(pre));
	count++;
	cout<<"Case "<<count<<": ";
	int re=1;
	long long l1=(Z*L+I) % M;
	pre[L] = l1; 
	int l2;
	while(1)
	{
		l2 = (Z*l1+I)%M;
		//cout<<"l2 = "<<l2<<endl;
		re++;
		if(find(l2) == l1)break;
		pre[l1] = l2;
		l1 = l2;
	}
//	cout<<re<<endl;
	//cout<<"ce"; 
	int l3 = L;
	for(int i=0;;i++)//找出周期的开始点
	{
		if(l3 == l2){re-=i;break;}
		l3 = (Z * l3 + I) % M;
	}
	cout<<re<<endl;
	}
	return 0;
	}
	
	
	
	

在一个思路呢就是,把每一个随机数都安排个一个老大,也就是一共有两级关系(一人之下万人之上~)初始化老大的时候都给他们为零,然后给每一个数都安排给1这个老大,如果算着算着发现摸一个随机数的老大就是1,那么就初步找到了循环节,后续的优化答案过程与上一个解法类似~~

#include<iostream>
#include<fstream>
#include<cstring>
using namespace std;

long long Z,I,M,L;
int map[100000];

int main()
{
long long count = 0;
while(cin>>Z>>I>>M>>L)
{
	if(Z==0&&I==0&&M==0&&L==0)break;
	memset(map,0,sizeof(map));
	count++;
	cout<<"Case "<<count<<": ";
	int re=1;
	long long L1=(Z*L+I) % M;
	//cout<<"L1 = "<<L1<<endl; 
	map[L]=1;
	while(1)
	{
		if(map[L1] == 1)break;
		re++;
		map[L1]=1;
		L1=(Z*L1+I)%M;
		//cout<<"re = "<<re<<endl ;
	}
	
	long long L2=L;
	for(int i=0;;i++)//找出周期的开始点
	{
		if(L2==L1){re-=i;break;}
		L2=(Z*L2+I)%M;
	}
	cout<<re<<endl;
	}
	return 0;
	}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值