HDU 1116 Play on Words 有向图欧拉回路的判断

点击打开链接

 

Play on Words

Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 4286    Accepted Submission(s): 1392


Problem Description
Some of the secret doors contain a very interesting word puzzle. The team of archaeologists has to solve it to open that doors. Because there is no other way to open the doors, the puzzle is very important for us.

There is a large number of magnetic plates on every door. Every plate has one word written on it. The plates must be arranged into a sequence in such a way that every word begins with the same letter as the previous word ends. For example, the word ``acm'' can be followed by the word ``motorola''. Your task is to write a computer program that will read the list of words and determine whether it is possible to arrange all of the plates in a sequence (according to the given rule) and consequently to open the door.
 


 

Input
The input consists of T test cases. The number of them (T) is given on the first line of the input file. Each test case begins with a line containing a single integer number Nthat indicates the number of plates (1 <= N <= 100000). Then exactly Nlines follow, each containing a single word. Each word contains at least two and at most 1000 lowercase characters, that means only letters 'a' through 'z' will appear in the word. The same word may appear several times in the list.
 


 

Output
Your program has to determine whether it is possible to arrange all the plates in a sequence such that the first letter of each word is equal to the last letter of the previous word. All the plates from the list must be used, each exactly once. The words mentioned several times must be used that number of times.
If there exists such an ordering of plates, your program should print the sentence "Ordering is possible.". Otherwise, output the sentence "The door cannot be opened.".
 


 

Sample Input
  
  
3 2 acm ibm 3 acm malform mouse 2 ok ok
 


 

Sample Output
  
  
The door cannot be opened. Ordering is possible. The door cannot be opened.
 


 

Source
 


 

Recommend
Eddy

 

 

题意是说给你n个单词,让你判断这些单词能不能首尾相接。

判断有向图是否是欧拉回路的判断方法是:

1)所有的点联通
2)欧拉回路中所有点的入度和出度一样,或者是欧拉通路中终点的入度 - 出度 = 1,起点的 初度 - 入度 = 1, 其他的所有点入度 = 出度;

 

#include<stdio.h>
#include<string.h>
int pre[26],in[26],out[26],vis[26],str[26];
char s[1007];
int n;

void init()
{
    for(int i=0;i<26;i++)
    {
        pre[i]=i;
        vis[i]=in[i]=out[i]=0;
    }
}

int find(int x)
{
    while(x!=pre[x])
        x=pre[x];
    return x;
}

void unio(int a,int b)
{
    int x=find(a);
    int y=find(b);
    if(x==y)return;
    pre[x]=y;
}

int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d",&n);
        init();
        for(int i=0;i<n;i++)
        {
            scanf("%s",s);
            int len=strlen(s);
            int a=s[0]-'a';
            int b=s[len-1]-'a';
            in[b]++;//每个字母的入度数
            out[a]++;//每个字母的出度数
            vis[a]=1;
            vis[b]=1;
            unio(a,b);
        }
        int count=0;
        for(int i=0;i<26;i++)
            if(pre[i]==i&&vis[i])
            {
                count++;
            }
        if(count>1)//如果不能一次全部相连
        {
            printf("The door cannot be opened.\n");
            continue;
        }
        int j=0;
        for(int i=0;i<26;i++)//当入度不等于出度时
        {
            if(in[i]!=out[i]&&vis[i])
                str[j++]=i;
        }
        if(j==0)
            printf("Ordering is possible.\n");
        else
            {
                if((j==2)&&((in[str[0]]-out[str[0]]==1)&&(out[str[1]]-in[str[1]]==1)||(in[str[1]]-out[str[1]]==1)&&(out[str[0]]-in[str[0]]==1)))
                    printf("Ordering is possible.\n");
                else
                    printf("The door cannot be opened.\n");
            }
    }
    return 0;
}


 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值