HDU 2680 Choose the best route 多源点+一汇点求最短路

点击打开链接

 

Choose the best route

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 5639    Accepted Submission(s): 1811


Problem Description
One day , Kiki wants to visit one of her friends. As she is liable to carsickness , she wants to arrive at her friend’s home as soon as possible . Now give you a map of the city’s traffic route, and the stations which are near Kiki’s home so that she can take. You may suppose Kiki can change the bus at any station. Please find out the least time Kiki needs to spend. To make it easy, if the city have n bus stations ,the stations will been expressed as an integer 1,2,3…n.
 


 

Input
There are several test cases.
Each case begins with three integers n, m and s,(n<1000,m<20000,1=<s<=n) n stands for the number of bus stations in this city and m stands for the number of directed ways between bus stations .(Maybe there are several ways between two bus stations .) s stands for the bus station that near Kiki’s friend’s home.
Then follow m lines ,each line contains three integers p , q , t (0<t<=1000). means from station p to station q there is a way and it will costs t minutes .
Then a line with an integer w(0<w<n), means the number of stations Kiki can take at the beginning. Then follows w integers stands for these stations.
 


 

Output
The output contains one line for each data set : the least time Kiki needs to spend ,if it’s impossible to find such a route ,just output “-1”.
 


 

Sample Input
  
  
5 8 5 1 2 2 1 5 3 1 3 4 2 4 7 2 5 6 2 3 5 3 5 1 4 5 1 2 2 3 4 3 4 1 2 3 1 3 4 2 3 2 1 1
 


 

Sample Output
  
  
1 -1
 


 

Author
dandelion
 


 

Source
 


 

Recommend
lcy

 

给你n个城市,m条路和终点s,给你w个起点,让你求从众多起点中选出一条到终点所需花费最少时间的路径。要注意 一下,这个图是有向图,如果每个起点到终点都遍历一遍的话,就会TLE。所有有两种解决方案:

1:将终点作为起点,起点作为终点,只需要一次Dijkstra就可以找出最短路径。

2:设一个超级源点,将各个起点与这个超级源点相邻,花费时间为0,其余的点与超级源点花费时间为inf。求超级源点到终点的最短路径。

 

方法一:

#include<stdio.h>
#include<string.h>
#define M 1007
#define inf 0x3f3f3f
using namespace std;
int vis[M],dis[M],g[M][M];
int n,m,s;

void Dijkstra(int s)
{
    int pos,minn;
    memset(vis,0,sizeof(vis));
    for(int i=1;i<=n;i++)
    {
        dis[i]=g[s][i];
    }
    dis[s]=0;
    vis[s]=1;
    for(int i=2;i<=n;i++)
    {
        minn=inf;
        for(int j=1;j<=n;j++)
            if(!vis[j]&&minn>dis[j])
            {
                minn=dis[j];
                pos=j;
            }
        if(minn==inf)break;
        vis[pos]=1;
        for(int j=1;j<=n;j++)
            if(!vis[j]&&dis[j]>dis[pos]+g[pos][j])
                dis[j]=dis[pos]+g[pos][j];
    }
}

int main()
{
    while(scanf("%d%d%d",&n,&m,&s)!=EOF)
    {
        for(int i=0;i<=n;i++)
            for(int j=0;j<=n;j++)
                if(i==j)
                    g[i][j]=0;
                else
                    g[i][j]=inf;
        int a,b,t,q,c;
        while(m--)
        {
            scanf("%d%d%d",&a,&b,&c);
            if(g[b][a]>c)
                g[b][a]=c;
        }
        scanf("%d",&q);
        Dijkstra(s);
        int minn=inf;
        for(int i=1;i<=q;i++)
        {
            scanf("%d",&t);
            if(minn>dis[t])
                minn=dis[t];
        }
        if(minn==inf)
            printf("-1\n");
        else
            printf("%d\n",minn);
    }
    return 0;
}


 

 

方法二:

 

#include<stdio.h>
#include<string.h>
#define M 1007
#define inf 0x3f3f3f
using namespace std;
int vis[M],dis[M],g[M][M];
int n,m,s;

int Dijkstra()
{
    int pos,minn;
    memset(vis,0,sizeof(vis));
    for(int i=0;i<=n;i++)
    {
        dis[i]=g[0][i];
    }
    dis[0]=0;
    vis[0]=1;
    for(int i=2;i<=n;i++)
    {
        minn=inf;
        for(int j=1;j<=n;j++)
            if(!vis[j]&&minn>dis[j])
            {
                minn=dis[j];
                pos=j;
            }
        if(minn==inf)break;
        vis[pos]=1;
        for(int j=1;j<=n;j++)
            if(!vis[j]&&dis[j]>dis[pos]+g[pos][j])
                dis[j]=dis[pos]+g[pos][j];
    }
    return dis[s];
}

int main()
{
    while(scanf("%d%d%d",&n,&m,&s)!=EOF)
    {
        for(int i=0;i<=n;i++)
            for(int j=0;j<=n;j++)
                if(i==j)
                    g[i][j]=0;
                else
                    g[i][j]=inf;
        int a,b,t,q,c;
        while(m--)
        {
            scanf("%d%d%d",&a,&b,&c);
            if(g[a][b]>c)
                g[a][b]=c;
        }
        scanf("%d",&q);
        for(int i=1;i<=q;i++)
        {
            scanf("%d",&t);
            g[0][t]=0;
        }
        int ans=Dijkstra();
        if(ans==inf)
            printf("-1\n");
        else
            printf("%d\n",ans);
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值