Choose the best route

题目:

One day , Kiki wants to visit one of her friends. As she is liable to carsickness , she wants to arrive at her friend’s
home as soon as possible . Now give you a map of the city’s traffic route, and the stations which are near Kiki’s home
so that she can take. You may suppose Kiki can change the bus at any station. Please find out the least time Kiki
needs to spend. To make it easy, if the city have n bus stations ,the stations will been expressed as an integer 1,2,3…n.

Input
There are several test cases.
Each case begins with three integers n, m and s,(n<1000,m<20000,1=<s<=n) n stands for the number of bus stations in this city and m stands for the number of directed ways between bus stations .(Maybe there are several ways between two bus stations .) s stands for the bus station that near Kiki’s friend’s home.
Then follow m lines ,each line contains three integers p , q , t (0<t<=1000). means from station p to station q there is a way and it will costs t minutes .
Then a line with an integer w(0<w<n), means the number of stations Kiki can take at the beginning. Then follows w integers stands for these stations.
Output
The output contains one line for each data set : the least time Kiki needs to spend ,if it’s impossible to find such a route ,just output “-1”.

Sample Input

5 8 5
1 2 2
1 5 3
1 3 4
2 4 7
2 5 6
2 3 5
3 5 1
4 5 1
2
2 3
4 3 4
1 2 3
1 3 4
2 3 2
1
1

Sample Output

1
-1

解题思路:这个是最短路经的题目,首先介绍样例:第一个5是五个公交站,8代表八条路径,第二个5是所到达的终点,接下来是家附近的公交站,然后求从该点出发到达终点的最短时间。
这个按正常思路容易超时,所以可以反过来求终点到各点的距离。

程序代码:

#include<stdio.h>
#include<string.h>
int e[2000][2000],dis[50000],book[50000];
int n,m,t;
int inf=99999999;
void dij()
{
	int i,j,k,u,v,min;
	for(i=1;i<=n;i++)
		dis[i]=e[t][i];
	for(i=1;i<=n;i++)
		book[i]=0;
	book[1]=1;
	for(i=1;i<n;i++)
	{
		min=inf;
		for(j=1;j<=n;j++)
		{
			if(book[j]==0&&dis[j]<min)
			{
				min=dis[j];
				u=j;
			}
		}
		book[u]=1;
		for(v=1;v<=n;v++)
		{
			if(e[u][v]<inf)
			{
				if(dis[v]>dis[u]+e[u][v])
					dis[v]=dis[u]+e[u][v];
			}
		}
	}
}
int main()
{
	int i,j,t1,t2,t3,a,b,c,d,tem;
	while(scanf("%d%d%d",&n,&m,&t)!=EOF)
	{
		memset(dis,0,sizeof(dis));
		memset(book,0,sizeof(book));
		for(i=1;i<=n;i++)
			for(j=1;j<=n;j++)
				if(i==j)	e[i][j]=0;
				else   		e[i][j]=inf;
		for(i=1;i<=m;i++)
		{
			scanf("%d%d%d",&t1,&t2,&t3);
			if(e[t1][t2]>t3)
				e[t1][t2]=t3;
		}
		for(i=1;i<n;i++)
			for(j=i+1;j<=n;j++)
			{
				tem=e[i][j];
				e[i][j]=e[j][i];
				e[j][i]=tem;
			}
		d=inf;
		dij();
//		for(i=1;i<=n;i++)
//			printf("*%d ",dis[i]);
//		printf("%d\n");
		scanf("%d",&a);
		for(i=1;i<=a;i++)
		{
			scanf("%d",&b);
		//	printf("*%d\n",dis[b]);
			if(d>dis[b])
				d=dis[b];		
		}
		if(d==inf)
			printf("-1\n");
		else
			printf("%d\n",d);
	}
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

我菜就爱学

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值