POJ 3625 Building Roads 存在建好的边

点击打开链接

Building Roads
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 8402 Accepted: 2428

Description

Farmer John had just acquired several new farms! He wants to connect the farms with roads so that he can travel from any farm to any other farm via a sequence of roads; roads already connect some of the farms.

Each of the N (1 ≤ N ≤ 1,000) farms (conveniently numbered 1..N) is represented by a position (XiYi) on the plane (0 ≤ X≤ 1,000,000; 0 ≤ Y≤ 1,000,000). Given the preexisting M roads (1 ≤ M ≤ 1,000) as pairs of connected farms, help Farmer John determine the smallest length of additional roads he must build to connect all his farms.

Input

* Line 1: Two space-separated integers: N and M
* Lines 2..N+1: Two space-separated integers: Xand Y
* Lines N+2..N+M+2: Two space-separated integers: i and j, indicating that there is already a road connecting the farm i and farm j.

Output

* Line 1: Smallest length of additional roads required to connect all farms, printed without rounding to two decimal places. Be sure to calculate distances as 64-bit floating point numbers.

Sample Input

4 1
1 1
3 1
2 3
4 3
1 4

Sample Output

4.00

Source



有n个点,n行为每个点的坐标,然后m行,每行为已建好的边,已建好的边将其权值设为0就可以,让你求最小生成树。注意精度问题。


#include<stdio.h>
#include<string.h>
#include<math.h>
#define M 1007
#define inf 0x3f3f3f
int vis[M];
double g[M][M],dis[M],x[M],y[M];
int n,m;
double distance(int i,int j)
{
    return sqrt((x[i]-x[j])*(x[i]-x[j])+(y[i]-y[j])*(y[i]-y[j]));
}
void prime()
{
    int pos;
    double minn,ans=0;
    memset(vis,0,sizeof(vis));
    for(int i=1;i<=n;i++)
        dis[i]=g[1][i];
    vis[1]=1;
    for(int i=1;i<n;i++)
    {
        minn=inf;
        pos=0;
        for(int j=1;j<=n;j++)
            if(!vis[j]&&minn>dis[j])
            {
                minn=dis[j];
                pos=j;
            }
        vis[pos]=1;
        ans+=minn;
        for(int j=1;j<=n;j++)
            if(!vis[j]&&dis[j]>g[pos][j])
                dis[j]=g[pos][j];
    }
    printf("%.2f\n",ans);
}
int main()
{
    while(scanf("%d%d",&n,&m)!=EOF)
    {
        for(int i=1;i<=n;i++)
            for(int j=1;j<=n;j++)
                if(i==j)g[i][j]=0;
                else g[i][j]=inf;
        int a,b;
        for(int i=1;i<=n;i++)
            scanf("%lf%lf",&x[i],&y[i]);
        for(int i=1;i<=n;i++)
            for(int j=1;j<=n;j++)
                if(i!=j)g[i][j]=distance(i,j);
        while(m--)
        {
            scanf("%d%d",&a,&b);
            g[a][b]=g[b][a]=0;
        }
        prime();
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值