HDU 1525&&POJ 2348 Euclid's Game 规律博弈(难)


Euclid's Game

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 1554    Accepted Submission(s): 701


Problem Description
Two players, Stan and Ollie, play, starting with two natural numbers. Stan, the first player, subtracts any positive multiple of the lesser of the two numbers from the greater of the two numbers, provided that the resulting number must be nonnegative. Then Ollie, the second player, does the same with the two resulting numbers, then Stan, etc., alternately, until one player is able to subtract a multiple of the lesser number from the greater to reach 0, and thereby wins. For example, the players may start with (25,7): 

25 7
11 7
4 7
4 3
1 3
1 0 

an Stan wins. 

 

Input
The input consists of a number of lines. Each line contains two positive integers giving the starting two numbers of the game. Stan always starts.
 

Output
For each line of input, output one line saying either Stan wins or Ollie wins assuming that both of them play perfectly. The last line of input contains two zeroes and should not be processed. 

 

Sample Input
   
   
34 12 15 24 0 0
 

Sample Output
   
   
Stan wins Ollie wins
 

Source


给你两个数A和B,每个人轮流从最大的那个数里面减去k倍的较小的数(k为整数),要求结果大于等于0,谁最后为0,谁wins。
如果A>B,一种情况是A/B>=2那么此人就可以选择至少两种策略,因此谁到了这种状态谁就会获胜,另一种情况就是A/B=1,此时只有一种策略。而且当A%B==0的时候也可以直接跳出,此点也为必胜点。

#include<stdio.h>
#include<algorithm>
using namespace std;
int main()
{
    int n,m;
    while(scanf("%d%d",&n,&m),n|m)
    {
        int count=0;
        if(n<m)swap(n,m);
        while(1)
        {
            if(m==0||n%m==0||n/m>=2)break;
            n%=m;
            swap(n,m);
            count++;
        }
        if(count&1)printf("Ollie wins\n");
        else printf("Stan wins\n");
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值