HDU 1059 Dividing 母函数


Dividing

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 14258    Accepted Submission(s): 3988


Problem Description
Marsha and Bill own a collection of marbles. They want to split the collection among themselves so that both receive an equal share of the marbles. This would be easy if all the marbles had the same value, because then they could just split the collection in half. But unfortunately, some of the marbles are larger, or more beautiful than others. So, Marsha and Bill start by assigning a value, a natural number between one and six, to each marble. Now they want to divide the marbles so that each of them gets the same total value. 
Unfortunately, they realize that it might be impossible to divide the marbles in this way (even if the total value of all marbles is even). For example, if there are one marble of value 1, one of value 3 and two of value 4, then they cannot be split into sets of equal value. So, they ask you to write a program that checks whether there is a fair partition of the marbles.
 

Input
Each line in the input describes one collection of marbles to be divided. The lines consist of six non-negative integers n1, n2, ..., n6, where ni is the number of marbles of value i. So, the example from above would be described by the input-line ``1 0 1 2 0 0''. The maximum total number of marbles will be 20000. 

The last line of the input file will be ``0 0 0 0 0 0''; do not process this line.
 

Output
For each colletcion, output ``Collection #k:'', where k is the number of the test case, and then either ``Can be divided.'' or ``Can't be divided.''. 

Output a blank line after each test case.
 

Sample Input
   
   
1 0 1 2 0 0 1 0 0 0 1 1 0 0 0 0 0 0
 

Sample Output
   
   
Collection #1: Can't be divided. Collection #2: Can be divided.
 

Source

给你六个数,分别代表有num[1]个1,num[2]个2......num[6]个6,让你判断它们总和能否均分。
母函数的基本应用。
//62MS	780K
#include<stdio.h>
#include<string.h>
#define M 70007
int c1[M],c2[M],num[7];
int main()
{
    int n,cas=1;
    while(scanf("%d%d%d%d%d%d",&num[1],&num[2],&num[3],&num[4],&num[5],&num[6])!=EOF)
    {
        for(int i=1;i<=6;i++)//不加这句就会TLE
              num[i]%=60;
        int count=num[1]+2*num[2]+3*num[3]+4*num[4]+5*num[5]+6*num[6];
        if(!count)break;
        if(count%2!=0){printf("Collection #%d:\n",cas++);printf("Can't be divided.\n\n");continue;}
        count/=2;
        memset(c1,0,sizeof(c1));//c1保存当前得到的多项式各项系数
        memset(c2,0,sizeof(c2));//c2保存每次计算时临时的结果
        for(int i=0;i<=c1[0];i++)c1[0]=1;
        for(int i=2; i<=6; i++) //要乘以5个多项式
        {
            for(int j=0; j<=count; j++) //c1的各项指数
                for(int k=0;k<=num[i]&&j+k*i<=count;k++)
                    c2[j+k*i]+=c1[j];//指数相加得j+k*i,加多少只取决于c1[j]的系数,因为被乘多项式的各项系数均为1
            memcpy(c1,c2,sizeof(c2));
            memset(c2,0,sizeof(c2));
        }
        printf("Collection #%d:\n",cas++);
        if(c1[count])printf("Can be divided.\n\n");
        else printf("Can't be divided.\n\n");
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 2
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 2
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值