HDU 1015 Safecracker 搜素回溯


Safecracker

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 7268    Accepted Submission(s): 3655


Problem Description
=== Op tech briefing, 2002/11/02 06:42 CST === 
"The item is locked in a Klein safe behind a painting in the second-floor library. Klein safes are extremely rare; most of them, along with Klein and his factory, were destroyed in World War II. Fortunately old Brumbaugh from research knew Klein's secrets and wrote them down before he died. A Klein safe has two distinguishing features: a combination lock that uses letters instead of numbers, and an engraved quotation on the door. A Klein quotation always contains between five and twelve distinct uppercase letters, usually at the beginning of sentences, and mentions one or more numbers. Five of the uppercase letters form the combination that opens the safe. By combining the digits from all the numbers in the appropriate way you get a numeric target. (The details of constructing the target number are classified.) To find the combination you must select five letters v, w, x, y, and z that satisfy the following equation, where each letter is replaced by its ordinal position in the alphabet (A=1, B=2, ..., Z=26). The combination is then vwxyz. If there is more than one solution then the combination is the one that is lexicographically greatest, i.e., the one that would appear last in a dictionary." 

v - w^2 + x^3 - y^4 + z^5 = target 

"For example, given target 1 and letter set ABCDEFGHIJKL, one possible solution is FIECB, since 6 - 9^2 + 5^3 - 3^4 + 2^5 = 1. There are actually several solutions in this case, and the combination turns out to be LKEBA. Klein thought it was safe to encode the combination within the engraving, because it could take months of effort to try all the possibilities even if you knew the secret. But of course computers didn't exist then." 

=== Op tech directive, computer division, 2002/11/02 12:30 CST === 

"Develop a program to find Klein combinations in preparation for field deployment. Use standard test methodology as per departmental regulations. Input consists of one or more lines containing a positive integer target less than twelve million, a space, then at least five and at most twelve distinct uppercase letters. The last line will contain a target of zero and the letters END; this signals the end of the input. For each line output the Klein combination, break ties with lexicographic order, or 'no solution' if there is no correct combination. Use the exact format shown below."
 

Sample Input
   
   
1 ABCDEFGHIJKL 11700519 ZAYEXIWOVU 3072997 SOUGHT 1234567 THEQUICKFROG 0 END
 

Sample Output
   
   
LKEBA YOXUZ GHOST no solution
 

Source


给你一个数值target和一串大写字母,每个字母都代表一个值,A代表1,B代表2,Z代表26.让你从给的一串字母中找出5个字母,使得v - w^2 + x^3 - y^4 + z^5 = target。如果含有多个,则按字典序输出这五个字母,如果找不到,则输出no solution。
把字符串从大到小排列,然后注意pow的原型是double pow(double x, double y),所以浮点型转换成整型的时候要+0.5。
//140MS	240K
#include<stdio.h>
#include<string.h>
#include<math.h>
#include<algorithm>
using namespace std;
int ans,len;
bool flag;
char s[107];
int num[107],vis[107],a[107];//a是存储要求的5个数
int cmp(char a,char b)
{
    return a>b;
}
void dfs(int k)//k代表层数
{
    if(flag)return;
    if(k==5)//如果找到五个数
    {
        if((a[0]-(int)(pow(a[1],2)+0.5)+(int)(pow(a[2],3)+0.5)-(int)(pow(a[3],4)+0.5)+(int)(pow(a[4],5)+0.5))==ans)//浮点型与整数型数据类型转换时要加0.5
        {
            flag=true;
            printf("%c%c%c%c%c\n",a[0]+'A'-1,a[1]+'A'-1,a[2]+'A'-1,a[3]+'A'-1,a[4]+'A'-1);//还原成字母
        }
        return ;
    }
    for(int i=0; i<len; i++)
        if(!vis[num[i]])
        {
            a[k]=num[i];
            vis[num[i]]=1;
            dfs(k+1);
            vis[num[i]]=0;
        }
}
int main()
{
    while(scanf("%d%s",&ans,s)!=EOF)
    {
        if(ans==0&&strcmp(s,"END")==0)break;
        len=strlen(s);
        sort(s,s+len,cmp);//从大到小排序
        for(int i=0; i<len; i++)//num存的是每个字母的值
            num[i]=s[i]-'A'+1;
        flag=false;
        dfs(0);
        if(!flag)printf("no solution\n");
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值