Safecracker HDU - 1015 (搜索)

=== Op tech briefing, 2002/11/02 06:42 CST === 
"The item is locked in a Klein safe behind a painting in the second-floor library. Klein safes are extremely rare; most of them, along with Klein and his factory, were destroyed in World War II. Fortunately old Brumbaugh from research knew Klein's secrets and wrote them down before he died. A Klein safe has two distinguishing features: a combination lock that uses letters instead of numbers, and an engraved quotation on the door. A Klein quotation always contains between five and twelve distinct uppercase letters, usually at the beginning of sentences, and mentions one or more numbers. Five of the uppercase letters form the combination that opens the safe. By combining the digits from all the numbers in the appropriate way you get a numeric target. (The details of constructing the target number are classified.) To find the combination you must select five letters v, w, x, y, and z that satisfy the following equation, where each letter is replaced by its ordinal position in the alphabet (A=1, B=2, ..., Z=26). The combination is then vwxyz. If there is more than one solution then the combination is the one that is lexicographically greatest, i.e., the one that would appear last in a dictionary." 

v - w^2 + x^3 - y^4 + z^5 = target 

"For example, given target 1 and letter set ABCDEFGHIJKL, one possible solution is FIECB, since 6 - 9^2 + 5^3 - 3^4 + 2^5 = 1. There are actually several solutions in this case, and the combination turns out to be LKEBA. Klein thought it was safe to encode the combination within the engraving, because it could take months of effort to try all the possibilities even if you knew the secret. But of course computers didn't exist then." 

=== Op tech directive, computer division, 2002/11/02 12:30 CST === 

"Develop a program to find Klein combinations in preparation for field deployment. Use standard test methodology as per departmental regulations. Input consists of one or more lines containing a positive integer target less than twelve million, a space, then at least five and at most twelve distinct uppercase letters. The last line will contain a target of zero and the letters END; this signals the end of the input. For each line output the Klein combination, break ties with lexicographic order, or 'no solution' if there is no correct combination. Use the exact format shown below." 

Input

1 ABCDEFGHIJKL
11700519 ZAYEXIWOVU
3072997 SOUGHT
1234567 THEQUICKFROG
0 END

Output

LKEBA
YOXUZ
GHOST
no solution

Sample Input

1 ABCDEFGHIJKL
11700519 ZAYEXIWOVU
3072997 SOUGHT
1234567 THEQUICKFROG
0 END

Sample Output

LKEBA
YOXUZ
GHOST
no solution

题意: 用字符串表示数字,在已知的字符串s中,遍历五个字符v、w、x、y、z,使公式v - w^2 + x^3 - y^4 + z^5 = n满足的最大字符串。


#include<iostream>
#include<string>
#include<string.h>
#include<algorithm>
#include<cstdio>
#include<cstdlib>
#include<queue>
#include<cmath>
#include<cctype>
#include<stack>
#include<cstring>
using namespace std;
#define res(v,w,x,y,z) v-w*w+x*x*x-y*y*y*y+z*z*z*z*z
int flag[100], mapp[100], f[5];
long n;
//搜索,step表示已经选择了的字符的数量,len表示原字符中还未选择的字符长度,n表示使公式等于的值;
int dfs(int step, int len, int n)
{
    if(step==5)
    {
        if(res(f[0], f[1], f[2], f[3], f[4])==n)//如果满足公式,返回1,否则返回0;
            return 1;
        return 0;
    }
    //从排好序的字符串的最后开始遍历;
    for(int i=len; i>=0; i--)
    {
        //如果字符已经被标记过,跳到下一循环;因为没有要求v, w, x, y, z的大小,所以会出现这种情况;
        if(flag[i]==1)
            continue;
        flag[i] = 1;//标记所选字符;
        f[step] = mapp[i];//字符存到f数组里;
        //遍历下一字符;
        if(dfs(step+1, len, n))
            return 1;
        flag[i] = 0;//取消标记;
    }
    return 0;
}
int main()
{
    char str[50];
    while(scanf("%d%s", &n, str)!=EOF)
    {
        //如果最后输入0 END,测试结束;
        if(n==0&&strcmp(str, "END")==0)
            break;
        int len = 0;
        //将字符串转化为数值,并且标记字符为0;
        while(str[len])
        {
            mapp[len] = str[len]-'A'+1;
            flag[len] = 0;
            len++;
        }
        sort(mapp, mapp+len);//将字符按升序排序;
        if(dfs(0, len-1, n))
        {
            //输出字符;
            for(int i=0; i<5; i++)
            {
                printf("%c", f[i]+'A'-1);
            }
            printf("\n");
        }
        else
            printf("no solution\n");
    }
    return 0;
}

 

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值