POJ 2183 Bovine Math Geniuses 找循环


Bovine Math Geniuses
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 2211 Accepted: 1364

Description

Farmer John loves to help the cows further their mathematical skills. He has promised them Hay-flavored ice cream if they can solve various mathematical problems. 

He said to Bessie, "Choose a six digit integer, and tell me what it is. Then extract the middle four digits. Square them and discard digits at the top until you have another number six digits or shorter. Tell me the result." 

Bessie, a mathematical genius in disguise, chose the six digit number 655554. "Moo: 6 5 5 5 5 4", she said. She then extracted the middle four digits: 5555 and squared them: 30858025. She kept only the bottom six digits: 858025. "Moo: 8 5 8 0 2 5", she replied to FJ. 

FJ nodded wisely, acknowledging Bessie's prowess in arithmetic. "Now keep doing that until you encounter a number that repeats a number already seen," he requested. 

Bessie decided she'd better create a table to keep everything straight: 
              Middle    Middle   Shrunk to

       Num   4 digits   square   6 or fewer

     655554    5555    30858025    858025

     858025    5802    33663204    663204

     663204    6320    39942400    942400

     942400    4240    17977600    977600

     977600    7760    60217600    217600 <-+

     217600    1760     3097600     97600   |

      97600    9760    95257600    257600   |

     257600    5760    33177600    177600   |

     177600    7760    60217600    217600 --+

Bessie showed her table to FJ who smiled and produced a big dish of delicious hay ice cream. "That's right, Bessie," he praised. "The chain repeats in a loop of four numbers, of which the first encountered was 217600. The loop was detected after nine iterations." 

Help the other cows win ice cream treats. Given a six digit number, calculate the total number of iterations to detect a loop, the first looping number encountered, and also the length of the loop. 

FJ wondered if Bessie knew all the tricks. He had made a table to help her, but she never asked: 
              Middle    Middle   Shrunk to

       Num   4 digits   square   6 or fewer

     200023    0002       4        4

          4       0       0        0

          0       0       0        0         [a self-loop]

whose results would be: three iterations to detect a loop, looping on 0, and a length of loop equal to 1. 

Remember: Your program can use no more than 16MB of memory. 

Input

* Line 1: A single six digit integer that is the start of the sequence testing. 

Output

* Line 1: Three space-separated integers: the first number of a loop, the length of the loop, and the minimum number of iterations to detect the loop. 

Sample Input

655554

Sample Output

217600 4 9

Source


给你一个六位数字,让你取中间四位数字,把它平方后得到一个新数,然后取这个新数中间的四位数字。
一直循环,一直找到重复的六位数字为止,输出循环次数,循环长度和循环前执行的操作。
//4300K	16MS
#include<stdio.h>
#include<string.h>
int vis[1000007];
int main()
{
    int x,i;
    scanf("%d",&x);
    memset(vis,-1,sizeof(vis));
    for(i=1;;i++)
    {
        x=x/10%10000;
        x*=x;x%=1000000;
        if(vis[x]>=0)break;
        vis[x]=i;
    }
    printf("%d %d %d\n",x,i-vis[x],i);
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值