HDU 1358 Period 求周期串(kmp)

Period

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 2458    Accepted Submission(s): 1218


Problem Description
For each prefix of a given string S with N characters (each character has an ASCII code between 97 and 126, inclusive), we want to know whether the prefix is a periodic string. That is, for each i (2 <= i <= N) we want to know the largest K > 1 (if there is one) such that the prefix of S with length i can be written as A K , that is A concatenated K times, for some string A. Of course, we also want to know the period K.
 

Input
The input file consists of several test cases. Each test case consists of two lines. The first one contains N (2 <= N <= 1 000 000) – the size of the string S. The second line contains the string S. The input file ends with a line, having the number zero on it.
 

Output
For each test case, output “Test case #” and the consecutive test case number on a single line; then, for each prefix with length i that has a period K > 1, output the prefix size i and the period K separated by a single space; the prefix sizes must be in increasing order. Print a blank line after each test case.
 

Sample Input
   
   
3 aaa 12 aabaabaabaab 0
 

Sample Output
   
   
Test case #1 2 2 3 3 Test case #2 2 2 6 2 9 3 12 4
给你一个字符串,让你求它所有的前缀能否形成周期串,如果可以输出周期串的循环次数,要求次数大于1.
kmp中的未优化的nex数组存的是字符串的前后缀最大匹配情况,可以根据这个求出每个前缀的最小周期的长度t,t=i-next[i],如果i%t==0,说明能够形成周期串,那么周期串的循环次数就是i/t.
//125MS	5144K
#include<stdio.h>
#include<string.h>
char pattern[1000007];
int next[1000007],m;
void pre()
{
	int i = 0, j = -1;
	next[0] = -1;
	while(i != m)
	{
		if(j == -1 || pattern[i] == pattern[j])
			next[++i] = ++j;
		else
			j = next[j];
	}
}
int main()
{
    int cas=1;
    while(scanf("%d",&m),m)
    {
        memset(next,0,sizeof(next));
        scanf("%s",pattern);
        pre();
        printf("Test case #%d\n",cas++);
        for(int i=1;i<=m;i++)
        {
            int len=i-next[i];//求第i个字符的最小周期
            if(i%len==0&&i/len!=1)//如果能够形成周期串且长度>1
                printf("%d %d\n",i,i/len);//输出循环次数
        }
        printf("\n");
    }
    return 0;
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值