HDU 1757 A Simple Math Problem 矩阵快速幂


A Simple Math Problem

Time Limit: 3000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 2936    Accepted Submission(s): 1767


Problem Description
Lele now is thinking about a simple function f(x).

If x < 10 f(x) = x.
If x >= 10 f(x) = a0 * f(x-1) + a1 * f(x-2) + a2 * f(x-3) + …… + a9 * f(x-10);
And ai(0<=i<=9) can only be 0 or 1 .

Now, I will give a0 ~ a9 and two positive integers k and m ,and could you help Lele to caculate f(k)%m.
 

Input
The problem contains mutiple test cases.Please process to the end of file.
In each case, there will be two lines.
In the first line , there are two positive integers k and m. ( k<2*10^9 , m < 10^5 )
In the second line , there are ten integers represent a0 ~ a9.
 

Output
For each case, output f(k) % m in one line.
 

Sample Input
   
   
10 9999 1 1 1 1 1 1 1 1 1 1 20 500 1 0 1 0 1 0 1 0 1 0
 

Sample Output
   
   
45 104
 

Author
linle
 

Source
 

f(x) = x.  x < 10 
 f(x) = a0 * f(x-1) + a1 * f(x-2) + a2 * f(x-3) + …… + a9 * f(x-10)   x >= 10
求f(k)%m

递推一般都可以用矩阵快速幂来解决,关键在于构造矩阵。
/*
                                                                            k-9
f(n)           a0  a1  a2  a3  a4  a5  a6  a7  a8  a9                     f9
f(n-1)        1    0    0   0    0    0    0   0     0     0                     f8
f(n-2)        0    1    0   0    0    0    0   0     0     0                     f7
f(n-3)        0    0    1   0    0    0    0   0     0     0                     f6
f(n-4)  =   0    0    0    1    0   0     0   0     0    0           *         f5
f(n-5)        0    0    0    0   1    0    0    0     0    0                     f4
f(n-6)        0    0    0    0   0    1    0    0     0    0                     f3
f(n-7)        0    0    0    0   0    0    1    0     0    0                     f2
f(n-8)        0    0    0    0   0    0    0    1     0    0                     f1
f(n-9)        0    0    0    0   0    0    0    0     1    0                     f0
*/
//15MS	1112K
#include<stdio.h>
#include<string.h>
#include<algorithm>
#include<math.h>
#define mod 10000007
#define ll __int64
using namespace std;
ll one[10];
struct Matrax
{
    ll m[11][11];
}a,per,tmp;
void init()//建立矩阵
{
    memset(a.m,0,sizeof(a.m));
    memset(per.m,0,sizeof(per.m));
    for(int i=0;i<10;i++)a.m[0][i]=one[i];
    for(int i=0;i<10;i++)a.m[i+1][i]=1;
    for(int i=0;i<10;i++)
        for(int j=0;j<10;j++)
            if(i==j)per.m[i][i]=1;
}
Matrax multi(Matrax a,Matrax b,ll m)//矩阵相乘
{
    Matrax c;
    for(int i=0;i<10;i++)
        for(int j=0;j<10;j++)
        {
            c.m[i][j]=0;
            for(int k=0;k<10;k++)
                c.m[i][j]=(c.m[i][j]+a.m[i][k]*b.m[k][j])%m;
        }
        return c;
}
Matrax power(ll k,ll m)//矩阵快速幂
{
    Matrax pp=a,ans=per;
    while(k)
    {
        if(k&1){ans=multi(ans,pp,m);k--;}
        else {k>>=1;pp=multi(pp,pp,m);}
    }
    return ans;
}
int main()
{
    ll k,m;
    while(scanf("%I64d%I64d",&k,&m)!=EOF)
    {
        ll sum=0;
        for(int i=0;i<10;i++)
            scanf("%I64d",&one[i]);
        init();
        Matrax ans=power(k-9,m);
        for(int i=0;i<10;i++)
            sum=(sum+ans.m[0][i]*(10-i-1))%m;
        printf("%I64d\n",sum);
    }
    return 0;
}


Python网络爬虫与推荐算法新闻推荐平台:网络爬虫:通过Python实现新浪新闻的爬取,可爬取新闻页面上的标题、文本、图片、视频链接(保留排版) 推荐算法:权重衰减+标签推荐+区域推荐+热点推荐.zip项目工程资源经过严格测试可直接运行成功且功能正常的情况才上传,可轻松复刻,拿到资料包后可轻松复现出一样的项目,本人系统开发经验充足(全领域),有任何使用问题欢迎随时与我联系,我会及时为您解惑,提供帮助。 【资源内容】:包含完整源码+工程文件+说明(如有)等。答辩评审平均分达到96分,放心下载使用!可轻松复现,设计报告也可借鉴此项目,该资源内项目代码都经过测试运行成功,功能ok的情况下才上传的。 【提供帮助】:有任何使用问题欢迎随时与我联系,我会及时解答解惑,提供帮助 【附带帮助】:若还需要相关开发工具、学习资料等,我会提供帮助,提供资料,鼓励学习进步 【项目价值】:可用在相关项目设计中,皆可应用在项目、毕业设计、课程设计、期末/期中/大作业、工程实训、大创等学科竞赛比赛、初期项目立项、学习/练手等方面,可借鉴此优质项目实现复刻,设计报告也可借鉴此项目,也可基于此项目来扩展开发出更多功能 下载后请首先打开README文件(如有),项目工程可直接复现复刻,如果基础还行,也可在此程序基础上进行修改,以实现其它功能。供开源学习/技术交流/学习参考,勿用于商业用途。质量优质,放心下载使用。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值