HDU 2055 An easy problem

     点击打开链接

 

An easy problem

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 9722    Accepted Submission(s): 6687


Problem Description
we define f(A) = 1, f(a) = -1, f(B) = 2, f(b) = -2, ... f(Z) = 26, f(z) = -26;
Give you a letter x and a number y , you should output the result of y+f(x).
 


 

Input
On the first line, contains a number T.then T lines follow, each line is a case.each case contains a letter and a number.
 


 

Output
for each case, you should the result of y+f(x) on a line.
 


 

Sample Input
  
  
6 R 1 P 2 G 3 r 1 p 2 g 3
 


 

Sample Output
  
  
19 18 10 -17 -14 -4
 


 

Author
8600
 


 

Source
 


 

Recommend
linle
 
 
还是比较简单的一道题。
#include<stdio.h>
int main()
{
    int m;
    scanf("%d",&m);
  char x[10];
    while(m--)
  {

        int y,z;
        scanf("%s%d",&x,&y);
        if(x[0]>='a'&&x[0]<='z')
        {
            z=-(x[0]-'a'+1);
            printf("%d\n",y+z);
        }
        if(x[0]>='A'&&x[0]<='Z')
        {
            z=x[0]-'A'+1;
            printf("%d\n",z+y);
        }

    }

    return 0;
}

 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值