HDU 2132 An easy problem(简单DP)

Problem Description

We once did a lot of recursional problem . I think some of them is easy for you and some if hard for you.
Now there is a very easy problem . I think you can AC it.
We can define sum(n) as follow:
if i can be divided exactly by 3 sum(i) = sum(i-1) + iii;else sum(i) = sum(i-1) + i;
Is it very easy ? Please begin to program to AC it…-_-

Input

The input file contains multilple cases.
Every cases contain only ont line, every line contains a integer n (n<=100000).
when n is a negative indicate the end of file.

Output

output the result sum(n).

Sample Input

1
2
3
-1

Sample Output

1
3
30

题目说是一道递归水题,看到测试数据是100000,我有点迟疑,但我还是天真的直接写了个递归的版本,提交,超时。。。

那就用动态规划呗,方程已经给了,遍历顺序从左到右,动态规划写倒是挺好写的。就是要注意一下测试数据很大,必须用longlong类型的dp数组。另外,遍历的变量i也要用longlong类型的,不然就是WA,不知为何,照理来说i的取值范围在100000以下,用int完全可以呀,难道是一个longlong类型的数组,下标也用longlong?hdu这里的评测有点不解。。。

longlong类型的变量输出用%lld和%I64d的格式限定符都可以

代码:

#include<iostream>
using namespace std;
#define ll long long 

const int maxn = 100001;
ll dp[maxn], i;


void Dp()
{
	dp[0] = 0;
	for(i = 1;i < maxn;i++)
	{
		if(i % 3 == 0)
			dp[i] = dp[i - 1] + i * i * i;
		else
			dp[i] = dp[i - 1] + i;
	}
}

int main()
{
	int n;
	Dp();
	while(scanf("%d", &n) && n >= 0)
	{
		printf("%lld\n", dp[n]);
	}
	return 0;
}

题目虽然短小简单,但涉及到dp的思想,既然重复利用,何不用一张数表将结果记录下来?一下将O(2 ^ n)的递归问题转换成O(n)的问题了

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值