Accurately Say "CocaCola"!

点击打开链接

 

 

Accurately Say "CocaCola"!

Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 65536/32768K (Java/Other)
Total Submission(s) : 25   Accepted Submission(s) : 8
Problem Description
             In a party held by CocaCola company, several students stand in a circle and play a game. 

One of them is selected as the first, and should say the number 1. Then they continue to count number from 1 one by one (clockwise). The game is interesting in that, once someone counts a number which is a multiple of 7 (e.g. 7, 14, 28, ...) or contains the digit '7' (e.g. 7, 17, 27, ...), he shall say "CocaCola" instead of the number itself. 

For example, 4 students play this game. At some time, the first one says 25, then the second should say 26. The third should say "CocaCola" because 27 contains the digit '7'. The fourth one should say "CocaCola" too, because 28 is a multiple of 7. Then the first one says 29, and the game goes on. When someone makes a mistake, the game ends. 

During a game, you may hear a consecutive of p "CocaCola"s. So what is the minimum number that can make this situation happen? 

For example p = 2, that means there are a consecutive of 2 "CocaCola"s. This situation happens in 27-28 as stated above. 27 is then the minimum number to make this situation happen. 

Input 

Standard input will contain multiple test cases. The first line of the input is a single integerT (1 <=T <= 100) which is the number of test cases. And it will be followed byT consecutive test cases. 

There is only one line for each case. The line contains only one integer p (1 <=p <= 99). 

Output 

Results should be directed to standard output. The output of each test case should be a single integer in one line, which is the minimum possible number for the first of thep "CocaCola"s stands for. 

Sample Input 

2
2
3

Sample Output 

27
70

 


 

Source
The 5th Zhejiang Provincial Collegiate Programming Contest
 
 
用了一种比较蛋疼的方法。
 
 
 

#include<stdio.h>
int main()
{
    int m;
    while(scanf("%d",&m)!=EOF)
    {
        while(m--)
        {
            int n;
            scanf("%d",&n);
            if(n==1)printf("7\n");
        else if(n==2)printf("27\n");
        else if(n>=3&&n<=10) printf("70\n");
        else if(n==11) printf("270\n");
        else if(n>11) printf("700\n");
        }

    }
    return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值