Proud Merchants
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 131072/65536 K (Java/Others)
Total Submission(s): 1609 Accepted Submission(s): 642
Problem Description
Recently, iSea went to an ancient country. For such a long time, it was the most wealthy and powerful kingdom in the world. As a result, the people in this country are still very proud even if their nation hasn’t been so wealthy any more.
The merchants were the most typical, each of them only sold exactly one item, the price was Pi, but they would refuse to make a trade with you if your money were less than Qi, and iSea evaluated every item a value Vi.
If he had M units of money, what’s the maximum value iSea could get?
The merchants were the most typical, each of them only sold exactly one item, the price was Pi, but they would refuse to make a trade with you if your money were less than Qi, and iSea evaluated every item a value Vi.
If he had M units of money, what’s the maximum value iSea could get?
Input
There are several test cases in the input.
Each test case begin with two integers N, M (1 ≤ N ≤ 500, 1 ≤ M ≤ 5000), indicating the items’ number and the initial money.
Then N lines follow, each line contains three numbers Pi, Qi and Vi (1 ≤ Pi ≤ Qi ≤ 100, 1 ≤ Vi ≤ 1000), their meaning is in the description.
The input terminates by end of file marker.
Each test case begin with two integers N, M (1 ≤ N ≤ 500, 1 ≤ M ≤ 5000), indicating the items’ number and the initial money.
Then N lines follow, each line contains three numbers Pi, Qi and Vi (1 ≤ Pi ≤ Qi ≤ 100, 1 ≤ Vi ≤ 1000), their meaning is in the description.
The input terminates by end of file marker.
Output
For each test case, output one integer, indicating maximum value iSea could get.
Sample Input
2 10 10 15 10 5 10 5 3 10 5 10 5 3 5 6 2 7 3
Sample Output
5 11
Author
iSea @ WHU
Source
Recommend
zhouzeyong
题意:每个人卖个商人一件物品价格是p,但是商人所拥有的价钱必须不少于q,物品的估是v,求商人能够得到的最大价值。
思路:按照p-q排序,因为最小用到q-p,要保证每次计算所用到的dp[j-c]已经是最后的结果,然后就是01背包问题。
#include<stdio.h>
#include<algorithm>
#include<string.h>
using namespace std;
int dp[5007]={0};
struct sa
{
int p,q,v;
}data[5007];
int max(int a,int b)
{
return a>b?a:b;
}
int cmp(const sa &a,const sa &b)
{
return a.q-a.p<b.q-b.p;
}
int main()
{
int n,m;
while(scanf("%d%d",&n,&m)!=EOF)
{
int i,j;
memset(dp,0,sizeof(dp));
for(i=1;i<=n;i++)
scanf("%d%d%d",&data[i].p,&data[i].q,&data[i].v);
sort(data+1,data+1+n,cmp);
for(i=1;i<=n;i++)
for(j=m;j>=data[i].q;j--)
{
dp[j]=max(dp[j],dp[j-data[i].p]+data[i].v);
}
printf("%d\n",dp[m]);
}
return 0;
}