UVA 11300 Spreading the Wealth 推导+中位数求解

点击打开链接

 


 F. Spreading the Wealth 

Problem

A Communist regime is trying to redistribute wealth in a village.  They have have decided to sit everyone around a circular table.  First, everyone has converted all of their properties to coins of equal value, such that the total number of coins is divisible by the number  of people in the village.  Finally, each person gives a number of coins to the person on his right and a number coins to the person on his left, such that in the end, everyone has the same number of coins.  Given the number of coins of each person,  compute the minimum number of coins that must be transferred using this method so that everyone  has the same number of coins. 

The Input

There is a number of inputs. Each input begins with n(n<1000001), the number of people in the village.n lines follow, giving the number of coins of each person in the village, in  counterclockwise order around the table.  The total number of coins will fit inside an unsigned 64 bit integer.

The Output

For each input, output the minimum number of coins that must be transferred on a single line.

Sample Input

3
100
100
100
4
1
2
5
4

Sample Output

0
4

 

题意:n个人围成一个圈,每个人都有一定数量金币,且金币总数能够被n整除,每个人可以给他左右的人一些金币数量,使最终每个人金币的数量都相等。让你求被转手的金币数量的最小值。

这个题需要你耐心的去推,具体推理过程就不说了,刘汝佳的书已经很详细了。最终转换成求点到中位数的问题。

 

#include<stdio.h>
#include<algorithm>
using namespace std;
#define MAX 9999999
long long s[MAX],z[MAX],tot,ave;
int main()
{
	int n;
	while(scanf("%d",&n)!=EOF)
	{
		tot=0,ave=0;
		for(int i=0;i<n;i++)
		{
			scanf("%lld",&s[i]);
			tot+=s[i];
		}
		ave=tot/n;
		z[0]=0;
		for(int i=1;i<n;i++)
		z[i]=z[i-1]+s[i]-ave;
		sort(z,z+n);
		long long x=z[n/2],ans=0;//x为中位数 
		for(int i=0;i<n;i++)
		ans+=abs(x-z[i]);//求每个点到x的距离 
		printf("%lld\n",ans);
	}
	return 0;
}


 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
"The following untracked working tree files would be overwritten by checkout"是一个Git命令的错误提示,表示在执行checkout命令时,有一些未被跟踪的工作树文件会被覆盖。这个错误通常发生在你在切换分支或恢复版本时。为了解决这个问题,你可以采取以下措施的一种或几种方法: 1. 提交或撤销更改:将你的工作树文件提交到版本库或者撤销这些更改,以确保工作树文件的状态与当前分支一致。 2. 储藏工作树文件:使用git stash命令将你的工作树文件储藏起来,然后执行checkout命令。完成checkout后,再使用git stash pop或git stash apply命令将储藏的工作树文件恢复到工作目录。 3. 强制执行checkout:如果你明确知道覆盖工作树文件不会导致丢失重要数据,你可以在checkout命令后添加-f或--force选项来强制执行。但是请注意,这可能会导致数据丢失,所以在使用强制选项之前请务必备份重要的文件。 请根据你的具体情况选择适合的解决方法来解决这个问题。<span class="em">1</span><span class="em">2</span><span class="em">3</span> #### 引用[.reference_title] - *1* *3* [git pull失败解决 git下“The following untracked working tree files would be overwritten by checkout](https://blog.csdn.net/wads23456/article/details/108347284)[target="_blank" data-report-click={"spm":"1018.2226.3001.9630","extra":{"utm_source":"vip_chatgpt_common_search_pc_result","utm_medium":"distribute.pc_search_result.none-task-cask-2~all~insert_cask~default-1-null.142^v93^chatsearchT3_2"}}] [.reference_item style="max-width: 50%"] - *2* [【Git】error: The following untracked working tree files would be overwritten by checkout](https://blog.csdn.net/weixin_42447823/article/details/127928015)[target="_blank" data-report-click={"spm":"1018.2226.3001.9630","extra":{"utm_source":"vip_chatgpt_common_search_pc_result","utm_medium":"distribute.pc_search_result.none-task-cask-2~all~insert_cask~default-1-null.142^v93^chatsearchT3_2"}}] [.reference_item style="max-width: 50%"] [ .reference_list ]

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值