HDU 1150 Machine Schedule 最小点覆盖数==最大匹配数

点击打开链接

 

Machine Schedule

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 4362    Accepted Submission(s): 2129


Problem Description
As we all know, machine scheduling is a very classical problem in computer science and has been studied for a very long history. Scheduling problems differ widely in the nature of the constraints that must be satisfied and the type of schedule desired. Here we consider a 2-machine scheduling problem.

There are two machines A and B. Machine A has n kinds of working modes, which is called mode_0, mode_1, …, mode_n-1, likewise machine B has m kinds of working modes, mode_0, mode_1, … , mode_m-1. At the beginning they are both work at mode_0.

For k jobs given, each of them can be processed in either one of the two machines in particular mode. For example, job 0 can either be processed in machine A at mode_3 or in machine B at mode_4, job 1 can either be processed in machine A at mode_2 or in machine B at mode_4, and so on. Thus, for job i, the constraint can be represent as a triple (i, x, y), which means it can be processed either in machine A at mode_x, or in machine B at mode_y.

Obviously, to accomplish all the jobs, we need to change the machine's working mode from time to time, but unfortunately, the machine's working mode can only be changed by restarting it manually. By changing the sequence of the jobs and assigning each job to a suitable machine, please write a program to minimize the times of restarting machines.
 


 

Input
The input file for this program consists of several configurations. The first line of one configuration contains three positive integers: n, m (n, m < 100) and k (k < 1000). The following k lines give the constrains of the k jobs, each line is a triple: i, x, y.

The input will be terminated by a line containing a single zero.
 


 

Output
The output should be one integer per line, which means the minimal times of restarting machine.
 


 

Sample Input
  
  
5 5 10 0 1 1 1 1 2 2 1 3 3 1 4 4 2 1 5 2 2 6 2 3 7 2 4 8 3 3 9 4 3 0
 


 

Sample Output
  
  
3
 


 

Source
 


 

Recommend
Ignatius.L

 

 

 

题意是说有k种任务可以用两种机器(A和B)去完成。A机器有n种工作状态,B机器有m种工作状态。每次任务,你都可以从这两种机器中选一台机器来执行,但是每更换一次机器工作状态都需要重启,让你求重启的最小次数。如果你能看出这个题是个二分匹配的题目,那就so easy了。将A,B看做定点,在对应的状态连线。因为每次任务都要完成,所以在两个定点中,必须有一个顶点存在。

即最小点覆盖问题。最小点覆盖=最大匹配数。

#include<stdio.h>
#include<string.h>
using namespace std;
int n,m,k;
int link[1007],g[1007][1007];
bool vis[1007];
struct node
{
    int x,y,z;
}box[1007];
bool judge(int i, int j)
{
    if(box[i].x<box[j].x&&box[i].y<box[j].y&&box[i].z<box[j].z)
    return true;
    return false;
}
bool find(int i)
{
    for(int j=1;j<=n;j++)
    if(g[i][j]&&!vis[j])
    {
        vis[j]=true;
        if(link[j]==0||find(link[j]))
        {
            link[j]=i;
            return true;
        }
    }
    return false;
}
int main()
{
    while(scanf("%d",&n),n)
    {
        scanf("%d%d",&m,&k);
        memset(g,0,sizeof(g));
        memset(link,0,sizeof(link));
        int num,a,b;
        for(int i=0;i<k;i++)
        {
            scanf("%d%d%d",&num,&a,&b);
            g[a][b]=1;
        }
        int count=0;
        for(int i=1;i<=n;i++)
        {
            memset(vis,false,sizeof(vis));
            if(find(i))
            count++;
        }
        printf("%d\n",count);
    }
    return 0;
}


 

 

 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值