数据结构实验之查找二:平衡二叉树

数据结构实验之查找二:平衡二叉树
Time Limit: 400 ms Memory Limit: 65536 KiB

Problem Description
根据给定的输入序列建立一棵平衡二叉树,求出建立的平衡二叉树的树根。

Input
输入一组测试数据。数据的第1行给出一个正整数N(n <= 20),N表示输入序列的元素个数;第2行给出N个正整数,按数据给定顺序建立平衡二叉树。

Output
输出平衡二叉树的树根。

Sample Input
5
88 70 61 96 120
Sample Output
70
Hint

Source
xam

#include <stdio.h>
#include <stdlib.h>

struct node
{
    int date;
    int bf; //平衡因子
    struct node *lchild;
    struct node *rchild;
};
int max(int a,int b);
int deep(struct node *root);
struct node *LL(struct node *root);
struct node *RR(struct node *root);
struct node *LR(struct node *root);
struct node *RL(struct node *root);
struct node *creat(struct node *root,int s);
int main()
{
    struct node *root;
    int i,n,s;
    scanf("%d",&n);
    root=NULL;
    for(i=1;i<=n;i++)
    {
        scanf("%d",&s);
        root=creat(root,s);
    }
    printf("%d\n",root->date);
    return 0;
}
int max(int a,int b)
{
    int max;
    if(a>b)
        max=a;
    else
        max=b;
    return max;
}
int deep(struct node *root)
{
    if(root==NULL)
        return -1;
    else
        return root->bf;
}
struct node *creat(struct node *root,int s)
{
    if(root==NULL)
    {
        root=(struct node*)malloc(sizeof(struct node));
        root->date=s;
        root->bf=0;
        root->lchild=NULL;
        root->rchild=NULL;
    }
    else
    {
        if(s<root->date)
        {
            root->lchild=creat(root->lchild,s);
            if(deep(root->lchild)-deep(root->rchild)>1)
            {
                if(s<root->lchild->date)
                    root=LL(root);
                else
                    root=LR(root);
            }
        }
        else
        {
            root->rchild=creat(root->rchild,s);
            if(deep(root->rchild)-deep(root->lchild)>1)
            {
                if(s>root->rchild->date)
                    root=RR(root);
                else
                    root=RL(root);
            }
        }
    }
    root->bf=max(deep(root->lchild),deep(root->rchild))+1;
    return root;
}
struct node *LL(struct node *root) //右旋转
{
    struct node *b;
    b=root->lchild;
    root->lchild=b->rchild;
    b->rchild=root;
    b->bf=max(deep(b->lchild),deep(b->rchild))+1;
    root->bf=max(deep(root->lchild),deep(root->rchild))+1;
    return b;
}
struct node *RR(struct node *root) //左旋转
{
    struct node *b;
    b=root->rchild;
    root->rchild=b->lchild;
    b->lchild=root;
    b->bf=max(deep(b->lchild),deep(b->rchild))+1;
    root->bf=max(deep(root->lchild),deep(root->rchild))+1;
    return b;
}
struct node *LR(struct node *root) //先右再左
{
    root->lchild=RR(root->lchild);
    return LL(root);
}
struct node *RL(struct node *root) //先左再右
{
    root->rchild=LL(root->rchild);
    return RR(root);
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值