hdu 4647

Another Graph Game

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1691    Accepted Submission(s): 630


Problem Description
Alice and Bob are playing a game on an undirected graph with n (n is even) nodes and m edges. Every node i has its own weight W v, and every edge e has its own weight W e.

They take turns to do the following operations. During each operation, either Alice or Bob can take one of the nodes from the graph that haven't been taken before. Alice goes first.

The scoring rule is: One person can get the bonus attached to a node if he/she have choosen that node before. One person can get the bonus attached to a edge if he/she have choosen both node that induced by the edge before.

You can assume Alice and Bob are intelligent enough and do operations optimally, both Alice and Bob's target is maximize their score - opponent's.

What is the final result for Alice - Bob.

 

Input
Muilticases. The first line have two numbers n and m.(1 <= n <= 10 5, 0<=m<=10 5) The next line have n numbers from W 1 to W n which W i is the weight of node i.(|W i|<=10 9)

The next m lines, each line have three numbers u, v, w,(1≤u,v≤n,|w|<=10 9) the first 2 numbers is the two nodes on the edge, and the last one is the weight on the edge. 
 

Output
One line the final result.

 

Sample Input
  
  
4 0 9 8 6 5
 

Sample Output
  
  
2
 

Source


#include <iostream>
#include <cstdio>
#include <string>
#include <algorithm>

using namespace std;
#define LL long long
#define maxn 100000 + 10

int n, m;
double a[maxn];

int main()
{
    while(~scanf("%d%d", &n, &m))
    {
        for(int i=1; i<=n; i++)
            scanf("%lfd", &a[i]);

        int u, v;
        double w;
        for(int i=1; i<=m; i++)
        {
            scanf("%d%d%lf", &u, &v, &w);
            w /= 2;
            a[u] += w;
            a[v] += w;
        }
        sort(a+1, a+1+n);
        double sum1 = 0, sum2 = 0;
        for(int i=n; i>=1; i--)
            {
                if(i & 1)
                    sum2 += a[i];
                else
                    sum1 += a[i];
            }
        printf("%.0lf\n", sum1 - sum2);
    }
    return 0;
}


  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值