FZU1752(快速幂+快速乘法)

Problem 1752 A^B mod C

Accept: 1126    Submit: 5065
Time Limit: 1000 mSec    Memory Limit : 32768 KB

Problem Description

Given A,B,C, You should quickly calculate the result of A^B mod C. (1<=A,B,C<2^63).

Input

There are multiply testcases. Each testcase, there is one line contains three integers A, B and C, separated by a single space.

Output

For each testcase, output an integer, denotes the result of A^B mod C.

Sample Input

3  2  4

2  10  1000

Sample Output

1

24


解法:快速乘法:例如:15x5=15+60;15x5=75=15+60;换成二进制就是代表 1111+111100=75;跟快速幂一样在乘数右移一位,被乘数左移一位,当乘数与1为真时   值加1;


#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
typedef long long ll;
typedef unsigned long long ull;
ll mulit(ll a,ll b,ll c)//快速乘
{
    ll ans=0;
    a%=c;
    while(b)
    {
        if(b&1)
        {
         ans+=a;
         if(ans>c){ans-=c;}//大于减c
        }
        a<<=1;
        if(a>=c)a-=c;
        b>>=1;
    }
    return ans;
}
ll quick(ll a,ll b,ll c)//求阶乘
{
    ll ans=1;
    while(b)
    {
        if(b&1){ans=mulit(ans,a,c);}
        a=mulit(a,a,c);
        b>>=1;
    }
    return ans;
}
int main()
{
    ll a,b,c;
    while(~scanf("%I64d%I64d%I64d",&a,&b,&c))
    {
        printf("%I64d\n",quick(a,b,c));
    }
    return   0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值