fzu1752(坑!!!)

Description

Given A,B,C, You should quickly calculate the result of A^B mod C. (1<=A,B,C<2^63).

Input

There are multiply testcases. Each testcase, there is one line contains three integers A, B and C, separated by a single space.

Output

For each testcase, output an integer, denotes the result of A^B mod C.

Sample Input

3 2 42 10 1000

Sample Output

124


这题太坑了,不想说了微笑!!!!!!数据大的可以卡死你




#include <iostream>
#include<stdio.h>
using namespace std;
typedef  __int64 ll;
ll quick(ll a,ll b,ll n)
{
    a=a%n;
    b=b%n;
    ll ans=0;
    while(b)
    {
    if(b&1)
    {
        ans=ans+a;
    if(ans>n)ans-=n;
    }
    a=a<<1;
    if(a>=n) a-=n;
        b>>=1;
    }
    return ans;
}
int main()
{
    ll a,b,n,ans;
    while(scanf("%I64d%I64d%I64d",&a,&b,&n)>0)
    {
        ans=1;
        a=a%n;
        while(b)
        {
            if(b&1)
            ans=quick(ans,a,n);
            a=quick(a,a,n);
            b>>=1;
        }
        printf("%I64d\n",ans);
    }
    return 0;
}



转载于:https://www.cnblogs.com/martinue/p/5490551.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值