FZU 1752 A^B mod C (快速幂+快乘)

Time Limit: 1000 mSec    Memory Limit : 32768 KB

Problem Description

Given A,B,C, You should quickly calculate the result of A^B mod C. (1<=A,B,C<2^63).

Input

There are multiply testcases. Each testcase, there is one line contains three integers A, B and C, separated by a single space.

Output

For each testcase, output an integer, denotes the result of A^B mod C.

Sample Input

3 2 42 10 1000

Sample Output

124

Source

FZU 2009 Summer Training IV--Number Theory


为了防止相乘溢出,所以就用加减来实现,此外这个oj不支持%lld 我在这里也出错了几次,大家要注意哦 !!


#include<stdio.h>
using namespace std;
#define ll long long
ll mulmod(ll a,ll b,ll c)
{
    ll ans=0;
    while(b)
    {
        if(b&1)
        {
            ans+=a;
            if(ans>=c) ans-=c;
        }
        a<<=1;
        if(a>=c)  a-=c;
        b>>=1;
    }
    return ans;
}
ll quickmod(ll a,ll b,ll c)
{
    ll ans=1;
    while(b)
    {
        if(b&1)
           ans=mulmod(ans,a,c);//这样写是为了使a*ans和a*a不溢出
        a=mulmod(a,a,c);
        b>>=1;
    }
    return ans;
}
int main()
{
    ll a,b,c ;
    while(~scanf("%I64d%I64d%I64d",&a,&b,&c))
    {
        a=a%c;
        printf("%I64d\n",quickmod(a,b,c));
    }
    return  0;
}




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值