POJ1984-Navigation Nightmare(带权并查集)

Navigation Nightmare

Time Limit: 2000MS Memory Limit: 30000K
Total Submissions: 7829 Accepted: 2817
Case Time Limit: 1000MS

Description

Farmer John's pastoral neighborhood has N farms (2 <= N <= 40,000), usually numbered/labeled 1..N. A series of M (1 <= M < 40,000) vertical and horizontal roads each of varying lengths (1 <= length <= 1000) connect the farms. A map of these farms might look something like the illustration below in which farms are labeled F1..F7 for clarity and lengths between connected farms are shown as (n): 

           F1 --- (13) ---- F6 --- (9) ----- F3

            |                                 |

           (3)                                |

            |                                (7)

           F4 --- (20) -------- F2            |

            |                                 |

           (2)                               F5

            | 

           F7 


Being an ASCII diagram, it is not precisely to scale, of course. 

Each farm can connect directly to at most four other farms via roads that lead exactly north, south, east, and/or west. Moreover, farms are only located at the endpoints of roads, and some farm can be found at every endpoint of every road. No two roads cross, and precisely one path 
(sequence of roads) links every pair of farms. 

FJ lost his paper copy of the farm map and he wants to reconstruct it from backup information on his computer. This data contains lines like the following, one for every road: 

There is a road of length 10 running north from Farm #23 to Farm #17 
There is a road of length 7 running east from Farm #1 to Farm #17 
... 

As FJ is retrieving this data, he is occasionally interrupted by questions such as the following that he receives from his navigationally-challenged neighbor, farmer Bob: 

What is the Manhattan distance between farms #1 and #23? 

FJ answers Bob, when he can (sometimes he doesn't yet have enough data yet). In the example above, the answer would be 17, since Bob wants to know the "Manhattan" distance between the pair of farms. 
The Manhattan distance between two points (x1,y1) and (x2,y2) is just |x1-x2| + |y1-y2| (which is the distance a taxicab in a large city must travel over city streets in a perfect grid to connect two x,y points). 

When Bob asks about a particular pair of farms, FJ might not yet have enough information to deduce the distance between them; in this case, FJ apologizes profusely and replies with "-1". 

Input

* Line 1: Two space-separated integers: N and M



* Lines 2..M+1: Each line contains four space-separated entities, F1,

        F2, L, and D that describe a road. F1 and F2 are numbers of

        two farms connected by a road, L is its length, and D is a

        character that is either 'N', 'E', 'S', or 'W' giving the

        direction of the road from F1 to F2.



* Line M+2: A single integer, K (1 <= K <= 10,000), the number of FB's

        queries



* Lines M+3..M+K+2: Each line corresponds to a query from Farmer Bob

        and contains three space-separated integers: F1, F2, and I. F1

        and F2 are numbers of the two farms in the query and I is the

        index (1 <= I <= M) in the data after which Bob asks the

        query. Data index 1 is on line 2 of the input data, and so on.

Output

* Lines 1..K: One integer per line, the response to each of Bob's

        queries.  Each line should contain either a distance

        measurement or -1, if it is impossible to determine the

        appropriate distance.

Sample Input

7 6
1 6 13 E
6 3 9 E
3 5 7 S
4 1 3 N
2 4 20 W
4 7 2 S
3
1 6 1
1 4 3
2 6 6

Sample Output

13
-1
10

Hint

At time 1, FJ knows the distance between 1 and 6 is 13. 
At time 3, the distance between 1 and 4 is still unknown. 
At the end, location 6 is 3 units west and 7 north of 2, so the distance is 10. 

Source

USACO 2004 February


题意:给你n个点给出两个点之间的距离和方位然后询问再给出i条数据后a,b能否连接 并且求出他们的曼哈顿距离

题解:先把点之间的信息离线存储,然后每次合并集的时候更新点信息就好了,每次合并利用的消息直接到i就好

有一个小知识:

fb.x=a.x-b.x+dx;

fb.y=a.y-b.y+dy;dx,dy 为a,b的相对距离,这样能求出fb,相对根的x,y坐标。


#include <cstdio>
#include <queue>
#include <algorithm>
#include <iostream>
#include <cstring>
#include <set>
#include <map>
using namespace std;
#define clr(a,b)   memset(a,b,sizeof(a))
#define rep(i,a,b) for(register int i=a;i<b;i++)
#define fi         first
#define reg        register
#define se         second
typedef long long ll;
const int maxn=40000+5;
const int minn=10000+4;
const int inf=1e10;
struct Edge
{
    int a,b,d;
    char t;
}edge[maxn];
struct Point
{
  int x,y;
}far[maxn];
struct  Pro
{
    int a,b,index;
    bool operator <(Pro &b)
    {
        return index<b.index;
    }
}pro[minn];
map<char,pair<int,int> >op;
int n,m,k,f[maxn];
int findt(int a)
{
    if(f[a]==a){return a;}
    int fa=f[a];
    f[a]=findt(f[a]);
    far[a].x+=far[fa].x;
    far[a].y+=far[fa].y;
    return f[a];
}
void link(int a,int b,char t,int len)
{
    int fa=findt(a);
    int fb=findt(b);
    f[fb]=fa;
    far[fb].x=far[a].x-far[b].x+op[t].fi*len;
    far[fb].y=far[a].y-far[b].y+op[t].se*len;
    return ;
}
int  dist(int a,int b)
{
    return abs(far[a].x-far[b].x)+abs(far[a].y-far[b].y);
}
int main()
{
    op['E'].fi=1;  op['E'].se=0;
    op['W'].fi=-1; op['W'].se=0;
    op['S'].fi=0;  op['S'].se=1;
    op['N'].fi=0;  op['N'].se=-1;
    // freopen("data.txt","r",stdin);
    clr(far,0);
    scanf("%d%d",&n,&m);
    rep(i,1,m+1)
    {
        scanf("%d%d%d %c",&edge[i].a,&edge[i].b,&edge[i].d,&edge[i].t);
        f[edge[i].a]=edge[i].a;
        f[edge[i].b]=edge[i].b;
    }
    scanf("%d",&k);
    int j=1,a,b,index;
    rep(i,1,k+1)
    {
        scanf("%d%d%d",&a,&b,&index);
        for(;j<=index;j++)
        {
            link(edge[j].a,edge[j].b,edge[j].t,edge[j].d);
        }
        if(findt(a)!=findt(b)){printf("-1\n");}
        else                  {printf("%d\n",dist(a,b));}
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值