Navigation Nightmare POJ - 1984(并查集)题解

    Farmer John's pastoral neighborhood has N farms (2 <= N <= 40,000), usually numbered/labeled 1..N. A series of M (1 <= M < 40,000) vertical and horizontal roads each of varying lengths (1 <= length <= 1000) connect the farms. A map of these farms might look something like the illustration below in which farms are labeled F1..F7 for clarity and lengths between connected farms are shown as (n): 
       F1 --- (13) ---- F6 --- (9) ----- F3

        |                                 |

       (3)                                |

        |                                (7)

       F4 --- (20) -------- F2            |

        |                                 |

       (2)                               F5

        | 

       F7 

    Being an ASCII diagram, it is not precisely to scale, of course. 

    Each farm can connect directly to at most four other farms via roads that lead exactly north, south, east, and/or west. Moreover, farms are only located at the endpoints of roads, and some farm can be found at every endpoint of every road. No two roads cross, and precisely one path 
(sequence of roads) links every pair of farms. 

    FJ lost his paper copy of the farm map and he wants to reconstruct it from backup information on his computer. This data contains lines like the following, one for every road: 

    There is a road of length 10 running north from Farm #23 to Farm #17 
    There is a road of length 7 running east from Farm #1 to Farm #17 
... 

    As FJ is retrieving this data, he is occasionally interrupted by questions such as the following that he receives from his navigationally-challenged neighbor, farmer Bob: 

What is the Manhattan distance between farms #1 and #23? 

FJ answers Bob, when he can (sometimes he doesn't yet have enough data yet). In the example above, the answer would be 17, since Bob wants to know the "Manhattan" distance between the pair of farms. 
The Manhattan distance between two points (x1,y1) and (x2,y2) is just |x1-x2| + |y1-y2| (which is the distance a taxicab in a large city must travel over city streets in a perfect grid to connect two x,y points). 

When Bob asks about a particular pair of farms, FJ might not yet have enough information to deduce the distance between them; in this case, FJ apologizes profusely and replies with "-1". 
Input
    * Line 1: Two space-separated integers: N and M
    * Lines 2..M+1: Each line contains four space-separated entities, F1,

    F2, L, and D that describe a road. F1 and F2 are numbers of

    two farms connected by a road, L is its length, and D is a

    character that is either 'N', 'E', 'S', or 'W' giving the

    direction of the road from F1 to F2.
* Line M+2: A single integer, K (1 <= K <= 10,000), the number of FB's

    queries



* Lines M+3..M+K+2: Each line corresponds to a query from Farmer Bob

    and contains three space-separated integers: F1, F2, and I. F1

    and F2 are numbers of the two farms in the query and I is the

    index (1 <= I <= M) in the data after which Bob asks the

    query. Data index 1 is on line 2 of the input data, and so on.
Output
* Lines 1..K: One integer per line, the response to each of Bob's

    queries.  Each line should contain either a distance

    measurement or -1, if it is impossible to determine the

    appropriate distance.
Sample Input
7 6
1 6 13 E
6 3 9 E
3 5 7 S
4 1 3 N
2 4 20 W
4 7 2 S
3
1 6 1
1 4 3
2 6 6
Sample Output
13
-1
10
Hint
At time 1, FJ knows the distance between 1 and 6 is 13. 
At time 3, the distance between 1 and 4 is still unknown. 
At the end, location 6 is 3 units west and 7 north of 2, so the distance is 10. 

并查集高效的地方就在于在使用F(x)函数查找x的父结点的时候会把沿途递归访问到的所有结点直接连到父节点上,使得下一次查询可以直接找到父节点,代码表示就是f[x]=F(f[x]);之前接触到的都是比较裸的并查集,但就像这题,维护并查集的时候还需要维护点到其父节点的距离,再构造F(x)函数时就得同时考虑对距离的维护,维护方式一旦不对就有可能导致距离错误。

这题的做法就是维护连通块内的结点到父节点的横轴距离和纵轴距离,查询时先判断是否属于同一两通块,若属于则将两点到父节点的横轴距离和纵轴距离相减求得曼哈顿距离即可。注意结点更新的操作。

#include<iostream>
#include<string.h>
#include<algorithm>
#include<stdio.h>
#include<cmath>
#include<string>
#include<stack>
#include<vector>
#define ll long long
using namespace std;
const int mod = 1000000007;
const int maxm = 40005;
const int maxn = 40005;
const int maxk = 10005;
const int inf = 0x3f3f3f3f;
int n, m,k;
int f[maxn];
int disx[maxn], disy[maxn];
int ans[maxk];
struct messg{
    int u, v, l;
    char dir;
}mes[maxm];
struct query{
    int u, v, idx,id;
    bool operator<(const query b)const{
        return idx < b.idx;
    }
}id[maxk];

int F(int x){
    if (f[x] == x)return x;
    int ff = f[x];
    int cc = F(f[x]);
    disx[x] += disx[ff];
    disy[x] += disy[ff];
    return f[x] = cc;
}

int main(){
    while (~scanf("%d%d", &n, &m)){
        for (int i = 1; i <= n; i++){ f[i] = i; }
        memset(disx, 0, sizeof(disx));
        memset(disy, 0, sizeof(disy));
        for (int i = 0; i < m; i++){
            scanf("%d%d%d%s", &mes[i].u, &mes[i].v, &mes[i].l, &mes[i].dir);
        }
        scanf("%d", &k);
        for (int i = 0; i < k; i++){
            scanf("%d%d%d", &id[i].u, &id[i].v, &id[i].idx);
            id[i].id = i;
        }
        sort(id, id + k);
        int cnt = 0;
        for (int i = 0; i < k; i++){
            while (cnt < id[i].idx){
                messg cur = mes[cnt];
                int f1 = F(cur.u);
                int f2 = F(cur.v);
                f[f1] = f2;
                disx[f1] = disx[cur.v]-disx[cur.u];
                disy[f1] = disy[cur.v]-disy[cur.u];
                if (cur.dir == 'N')disy[f1] += cur.l;
                else if (cur.dir == 'S')disy[f1] -= cur.l;
                else if (cur.dir == 'W')disx[f1] += cur.l;
                else disx[f1] -= cur.l;
                cnt++;
            }
            if (F(id[i].u) != F(id[i].v)){ ans[id[i].id] = -1; }
            else{
                int a = abs(disx[id[i].u] - disx[id[i].v]);
                a += abs(disy[id[i].u] - disy[id[i].v]);
                ans[id[i].id] = a;
            }
        }
        for (int i = 0; i < k; i++){ printf("%d\n", ans[i]); }
    }
    return 0;
}
  • 2
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值