【Jason's_ACM_解题报告】Andy's First Dictionary

Andy's First Dictionary

Andy, 8, has a dream - he wants to produce his very own dictionary. This is not an easy task for him, as the number of words that he knows is, well, not quite enough. Instead of thinking up all the words himself, he has a briliant idea. From his bookshelf he would pick one of his favourite story books, from which he would copy out all the distinct words. By arranging the words in alphabetical order, he is done! Of course, it is a really time-consuming job, and this is where a computer program is helpful.



You are asked to write a program that lists all the different words in the input text. In this problem, a word is defined as a consecutive sequence of alphabets, in upper and/or lower case. Words with only one letter are also to be considered. Furthermore, your program must be CaSe InSeNsItIvE. For example, words like "Apple", "apple" or "APPLE" must be considered the same.


Input
The input file is a text with no more than 5000 lines. An input line has at most 200 characters. Input is terminated by EOF.


Output
Your output should give a list of different words that appears in the input text, one in a line. The words should all be in lower case, sorted in alphabetical order. You can be sure that he number of distinct words in the text does not exceed 5000.


Sample Input
Adventures in Disneyland


Two blondes were going to Disneyland when they came to a fork in the
road. The sign read: "Disneyland Left."


So they went home.


Sample Output
a
adventures
blondes
came
disneyland
fork
going
home
in
left
read
road
sign
so
the
they
to
two
went
were
when


简单题目,主要训练set的用法,如insert(),注意当元素插入set中后,set自动维护元素有序,string类中已定义小于号。

此处还利用了cctype头文件中的两个函数,isalpha()和tolower(),前者判别参数是否为字母,后者将参数转为小写。

此外还用到了stringstream它的用法和cin,cout类似。


附代码如下:

我的写法:

#include<set>
#include<string>
#include<sstream>
#include<iostream>


using namespace std;

set<string> ab;

int main(){
	string s;
	while(cin>>s){
		for(int i=0;i<s.size();i++){
			if('A'<=s[i]&&s[i]<='Z')s[i]=s[i]-'A'+'a';
				else if('z'<s[i]||s[i]<'a')s[i]=' ';
		}
		stringstream ss(s);
		string x;
		while(ss>>x)ab.insert(x);
	}
	
	for(set<string>::iterator i=ab.begin();i!=ab.end();i++){
		cout<<*i<<endl;
	}
	
	return 0;
}

Liu的写法(使用cctype):

#include<set>
#include<cctype>
#include<string>
#include<sstream>
#include<iostream>


using namespace std;

set<string> ab;

int main(){
	string s;
	while(cin>>s){
		for(int i=0;i<s.size();i++){
			if(isalpha(s[i]))s[i]=tolower(s[i]);else s[i]=' ';
		}
		stringstream ss(s);
		string x;
		while(ss>>x)ab.insert(x);
	}
	
	for(set<string>::iterator i=ab.begin();i!=ab.end();i++){
		cout<<*i<<endl;
	}
	
	return 0;
}

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值