Matrix Chain Multiplication

Description

Suppose you have to evaluate an expression like A*B*C*D*E where A,B,C,D and E are matrices. Since matrix multiplication is associative, the order in which multiplications are performed is arbitrary. However, the number of elementary multiplications needed strongly depends on the evaluation order you choose.

For example, let A be a 50*10 matrix, B a 10*20 matrix and C a 20*5 matrix. There are two different strategies to compute A*B*C, namely (A*B)*C and A*(B*C).

The first one takes 15000 elementary multiplications, but the second one only 3500.

Your job is to write a program that determines the number of elementary multiplications needed for a given evaluation strategy.

Input Specification

Input consists of two parts: a list of matrices and a list of expressions.

The first line of the input file contains one integer n ( tex2html_wrap_inline28 ), representing the number of matrices in the first part. The next n lines each contain one capital letter, specifying the name of the matrix, and two integers, specifying the number of rows and columns of the matrix.

The second part of the input file strictly adheres to the following syntax (given in EBNF):

SecondPart = Line { Line } <EOF>
Line       = Expression <CR>
Expression = Matrix | "(" Expression Expression ")"
Matrix     = "A" | "B" | "C" | ... | "X" | "Y" | "Z"

Output Specification

For each expression found in the second part of the input file, print one line containing the word "error" if evaluation of the expression leads to an error due to non-matching matrices. Otherwise print one line containing the number of elementary multiplications needed to evaluate the expression in the way specified by the parentheses.

Sample Input

9
A 50 10
B 10 20
C 20 5
D 30 35
E 35 15
F 15 5
G 5 10
H 10 20
I 20 25
A
B
C
(AA)
(AB)
(AC)
(A(BC))
((AB)C)
(((((DE)F)G)H)I)
(D(E(F(G(HI)))))
((D(EF))((GH)I))

Sample Output

0
0
0
error
10000
error
3500
15000
40500
47500
15125
一开始考虑复杂了,认为括号里面不一定是两个数。代码如下:
#include<iostream>
#include<cstdio>
#include<string>
#include<vector>
#include<stack>
#include<cctype>
using namespace std;

typedef vector<int> VEC;
VEC f[28]; 

int main()
{
	int n;
	cin>>n;
	for(int i=0;i<n;i++)
	{
		string a;
		int r,c;
		cin>>a>>r>>c;
		f[a[0]-'A'].push_back(r);
		f[a[0]-'A'].push_back(c); 
	}
	string s;
	while(cin>>s)
	{
		stack<VEC> mat; //栈的元素是vector 
		bool ok=true;
		int sum=0;
		for(int i=0;i<s.length();i++)
		{
			if(isalpha(s[i])) mat.push(f[s[i]-'A']);
			if(s[i]==')')
			{
				VEC fir,sec;
				fir=mat.top();mat.pop();
				sec=mat.top();
				if(fir[0]!=sec[1])
				{
					ok=false;
					break;
				}
				sum+=fir[0]*fir[1]*sec[0];
				sec[1]=fir[1];
				mat.top()=sec;
			}
		}
		if(ok) printf("%d\n",sum);
		else printf("error\n");
	}
	return 0;
}
第一遍写读入:A 10 20……的函数是这样写的:
for(int i=0;i<n;i++)
	{
		char a;
		int r,c;
		scanf("%c%d%d",&a,&r,&c);
		x=a-'A'; 
		f[x].push_back(r);
		f[x].push_back(c);
	}

运行时出错了,原因在于输入n之后我敲了回车,而回车也算是字符,被读入了。后来改成string就可以了,因为string是不读入回车符的。(字符真是让人头疼==)
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值