HDU 1016 Prime Ring Problem

Prime Ring Problem

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 20806    Accepted Submission(s): 9300


Problem Description
A ring is compose of n circles as shown in diagram. Put natural number 1, 2, ..., n into each circle separately, and the sum of numbers in two adjacent circles should be a prime.

Note: the number of first circle should always be 1.


 

Input
n (0 < n < 20).
 

Output
The output format is shown as sample below. Each row represents a series of circle numbers in the ring beginning from 1 clockwisely and anticlockwisely. The order of numbers must satisfy the above requirements. Print solutions in lexicographical order.

You are to write a program that completes above process.

Print a blank line after each case.
 

Sample Input
  
  
6 8
 

Sample Output
  
  
Case 1: 1 4 3 2 5 6 1 6 5 2 3 4 Case 2: 1 2 3 8 5 6 7 4 1 2 5 8 3 4 7 6 1 4 7 6 5 8 3 2 1 6 7 4 3 8 5 2
 

Source
 

Recommend
JGShining
素数环要求,每两个数的和为素数,第一个和最后一个数也是素数。。。。。。这里我在写深搜集的时候 。没输出 。。纠结半天。。出来了。。。
#include<iostream>
#include<cstring>
using namespace std;
int prime[1000];
int a[21];
int vis[21];
void dfs(int n,int t)
{
	int i;
	if(t>n&&!prime[a[n]+1])
	{
		for(i=1;i<=n;i++)
			if(i<n)
				cout<<a[i]<<' ';
			else 
				cout<<a[i]<<endl;
			return;

	}
	for(i=2;i<=n;i++)
	{
		if(!vis[i]&&!prime[a[t-1]+i])
        {
             a[t]=i;
			 vis[i]=1;
			 dfs(n,t+1);
			 vis[i]=0;
		}
	}
}
int main()
{
	int n;	
	memset(prime,0,sizeof(prime));
    prime[0]=prime[1]=1;
    for(int i=2;i<1000;i++)
		if(!prime[i])
		{
			for(int j=i*2;j<1000;j+=i)
				 prime[j]=1;
		}
		i=1;
	while(cin>>n)
	{ 
		 
		cout<<"Case "<<i++<<':'<<endl;
		memset(vis,0,sizeof(vis));
		a[0]=a[1]=1;
		vis[0]=vis[1]=1;
		dfs(n,2);//从2开始
		cout<<endl;
	}
	return 0;
}

#include <iostream>
#include <string.h>
#include <math.h>
#include <stdio.h>
using namespace std;
bool prim[40];
int num[25];
bool used[25];
//筛法
void is_prim()
{
    memset(prim,0,sizeof(prim));
    prim[0]=prim[1]=1;
    int sq=sqrt((double)40);
    for(int i=2;i<sq;i++)
        for(int j=i*i;j<40;j+=i)
            prim[j]=1;
}
void dfs(int root,int n,int t)
{
    //数组从1开始,工n个数,当t>n时,说明n个数已排好序
    if(t>n&&!prim[num[n]+num[1]])
    {
        for(int j=1;j<n;j++)
            printf("%d ",num[j]);
        printf("%d\n",num[n]);
        return;
    }
    for(int i=1;i<=n;i++)
    {
        if(!prim[root+i]&&!used[i])
        {
            num[t]=i;
            used[i]=1;
            dfs(i,n,t+1);
            used[i]=0;
        }

    }
}
int main()
{
    is_prim();
    int n;
    int cas=1;
    while(scanf("%d",&n)!=EOF)
    {
        memset(used,0,sizeof(used));
        printf("Case %d:\n",cas++);
        num[1]=1;//第一个数一定是1
        used[1]=1;
        dfs(1,n,2);
        used[1]=0;
        printf("\n");

    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
蛋白质是生物体中普遍存在的一类重要生物大分子,由天然氨基酸通过肽键连接而成。它具有复杂的分子结构和特定的生物功能,是表达生物遗传性状的一类主要物质。 蛋白质的结构可分为四级:一级结构是组成蛋白质多肽链的线性氨基酸序列;二级结构是依靠不同氨基酸之间的C=O和N-H基团间的氢键形成的稳定结构,主要为α螺旋和β折叠;三级结构是通过多个二级结构元素在三维空间的排列所形成的一个蛋白质分子的三维结构;四级结构用于描述由不同多肽链(亚基)间相互作用形成具有功能的蛋白质复合物分子。 蛋白质在生物体内具有多种功能,包括提供能量、维持电解质平衡、信息交流、构成人的身体以及免疫等。例如,蛋白质分解可以为人体提供能量,每克蛋白质能产生4千卡的热能;血液里的蛋白质能帮助维持体内的酸碱平衡和血液的渗透压;蛋白质是组成人体器官组织的重要物质,可以修复受损的器官功能,以及维持细胞的生长和更新;蛋白质也是构成多种生理活性的物质,如免疫球蛋白,具有维持机体正常免疫功能的作用。 蛋白质的合成是指生物按照从脱氧核糖核酸(DNA)转录得到的信使核糖核酸(mRNA)上的遗传信息合成蛋白质的过程。这个过程包括氨基酸的活化、多肽链合成的起始、肽链的延长、肽链的终止和释放以及蛋白质合成后的加工修饰等步骤。 蛋白质降解是指食物中的蛋白质经过蛋白质降解酶的作用降解为多肽和氨基酸然后被人体吸收的过程。这个过程在细胞的生理活动中发挥着极其重要的作用,例如将蛋白质降解后成为小分子的氨基酸,并被循环利用;处理错误折叠的蛋白质以及多余组分,使之降解,以防机体产生错误应答。 总的来说,蛋白质是生物体内不可或缺的一类重要物质,对于维持生物体的正常生理功能具有至关重要的作用。

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值