HDU 1016 prime ring problem

A ring is compose of n circles as shown in diagram. Put natural number 1, 2, ..., n into each circle separately, and the sum of numbers in two adjacent circles should be a prime. 

Note: the number of first circle should always be 1. 

 
Input
n (0 < n < 20). 
Output
The output format is shown as sample below. Each row represents a series of circle numbers in the ring beginning from 1 clockwisely and anticlockwisely. The order of numbers must satisfy the above requirements. Print solutions in lexicographical order. 

You are to write a program that completes above process. 

Print a blank line after each case. 
Sample Input
6
8
Sample Output
Case 1:
1 4 3 2 5 6
1 6 5 2 3 4

Case 2:
1 2 3 8 5 6 7 4
1 2 5 8 3 4 7 6
1 4 7 6 5 8 3 2

1 6 7 4 3 8 5 2

这道题用dfs就可以ac了,有几个小点,首先是这道题目里面的n的范围是0到20,0到40的范围之内,就只有

12个素数,所以可以直接用一个数组储存所有的素数,当用完一个数字之后要做好标记,但是当回退的时候,

要把标记还原,由于是一个环,那么最后的那个数字和第一个数字也就是1的和,也要是素数,题目里面有

要求正向和反向的输出,但是直接用dfs可以直接输出所有的结果,最后一个数字输出之后,是不能有空格

的,要注意presentation error

#include<iostream>
#include<cstring>
using namespace std;
#define N 25
int prime[12] = {2,3,5,7,11,13,17,19,23,29,31,37};
int mark[N];
int putin[N];
int n;

bool is_prime(int a,int b)
{
    for(int i = 0;i<12;i++)
        if((a+b)==prime[i]) return true;
    return false;
}

int DFS(int k)
{
    if(k>n&&is_prime(putin[k-1],1))
    {
        for(int i = 1;i<n;i++)
        {
            cout<<putin[i]<<" ";
        }
        cout<<putin[n]<<endl;
    }
    else
    {
        for(int i = 2;i<=n;i++)
        {
            putin[k] = i;
            if(is_prime(i,putin[k-1])&&!mark[i])
            {
                mark[i] = 1;
                DFS(k+1);
            }
            for(int j = 1;j<=k-1;j++)
            {
                if(putin[j]==i)
                {
                    mark[i] = 1;
                    break;
                }
                mark[i] = 0;
            }
        }
    }
    return 0;
}

int main()
{
    int times = 0;
    while(cin>>n)
    {
        cout<<"Case "<<++times<<":"<<endl;
        memset(putin,0,sizeof(putin));
        memset(mark,0,sizeof(mark));
        putin[1] = 1;
        mark[1] = 1;
        DFS(2);
        cout<<endl;
    }
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值