hdu 1016Prime Ring Problem



Prime Ring Problem

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 47348    Accepted Submission(s): 20921


Problem Description
A ring is compose of n circles as shown in diagram. Put natural number 1, 2, ..., n into each circle separately, and the sum of numbers in two adjacent circles should be a prime.

Note: the number of first circle should always be 1.


 

Input
n (0 < n < 20).
 

Output
The output format is shown as sample below. Each row represents a series of circle numbers in the ring beginning from 1 clockwisely and anticlockwisely. The order of numbers must satisfy the above requirements. Print solutions in lexicographical order.

You are to write a program that completes above process.

Print a blank line after each case.
 

Sample Input
 
      
6 8
 

Sample Output
 
      
Case 1: 1 4 3 2 5 6 1 6 5 2 3 4 Case 2: 1 2 3 8 5 6 7 4 1 2 5 8 3 4 7 6 1 4 7 6 5 8 3 2 1 6 7 4 3 8 5 2
#include<iostream>
#include<string>
#include<memory.h>
#include<algorithm>
using namespace std;
int primer[40]={0,1,1,1,0,1,0,1,0,0,0,1,0,1,0,0,0,1,0,1,0,0,0,1,0,0,0,0,0,1,0,1,0,0,0,0,0,1,0,0};
int n,k=1,a[100],sum;
int visited[100];
void dfs(int m)
{
	if(m==n&&primer[a[m-1]+a[0]]==1)//找到最后一个数且首尾和为素数
	{
	   for(int i=0;i<n-1;i++)
	       cout<<a[i]<<" ";
	   cout<<a[n-1]<<endl; 
   }
   else//没有找到最后一个 
   {
        for(int i=2;i<=n;i++)//从2到n-1找
		{
		    if(visited[i]==0&&primer[i+a[m-1]]==1)//没有被访问过且和前一个的和为素数 
			{ 
			    visited[i]=1;//标记访问过
				a[m++]=i;//存入数据方便下次输出
				dfs(m);//递归找
				visited[i]=0;//返回2重新找 
				m--;//下次寻找 
			} 
		} 
   }	
}
int main() 
{
	while(cin>>n)
	{ 
	  memset(visited,0,sizeof(visited));//标记状态
	  cout<<"Case "<<k<<":"<<endl;
	  k++;
	  a[0]=1;//数组保存一个素数环 
	  dfs(1);//从1开始搜 (必须从1开始) 
	  cout<<endl;
	}
	return 0;
}
    





 


 

转载于:https://www.cnblogs.com/xunalove/p/6809230.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值