HDU 1163 Eddy's digital Roots(数论)

Eddy's digital Roots

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 3555    Accepted Submission(s): 2008


Problem Description
The digital root of a positive integer is found by summing the digits of the integer. If the resulting value is a single digit then that digit is the digital root. If the resulting value contains two or more digits, those digits are summed and the process is repeated. This is continued as long as necessary to obtain a single digit.

For example, consider the positive integer 24. Adding the 2 and the 4 yields a value of 6. Since 6 is a single digit, 6 is the digital root of 24. Now consider the positive integer 39. Adding the 3 and the 9 yields 12. Since 12 is not a single digit, the process must be repeated. Adding the 1 and the 2 yeilds 3, a single digit and also the digital root of 39.

The Eddy's easy problem is that : give you the n,want you to find the n^n's digital Roots.
 

Input
The input file will contain a list of positive integers n, one per line. The end of the input will be indicated by an integer value of zero. Notice:For each integer in the input n(n<10000).
 

Output
Output n^n's digital root on a separate line of the output.
 

Sample Input
  
  
2 4 0
 

Sample Output
  
  
4 4
 

Author
eddy
 

Recommend
JGShining

题目大意:

 给定一个正整数,根据一定的规则求出该数的数根,其规则如下:

        例如给定 数字 24,将24的各个位上的数字分离,分别得到数字 和 4,而2+4=6

        因为 6 < 10,所以就认为6是数字24数根

        而对于数字 39  将39的各个位上的数字分离,分别得到数字 和 9,而3+9=12,12>10

       所以依据规则再对 12 进行相应的运算,最后得到数字3,而3<10,所以就认为3是数字39数根

       

              通过运算可以发现任何一个数的数根都是一个取值范围在 1 ~ 9之间的正整数,

     且任何一个正整数都只有唯一的一个数根与其相对应。

              题目要求数字 n^n 数根

解题思路:

九余数定理

一个数对九取余后的结果称为九余数。

一个数的各位数字之和想加后得到的<10的数字称为这个数的九余数(如果相加结果大于9,则继续各位相加)

#include<iostream>
#include<cstdio>
#include<cstring>
#include<string>
#include<algorithm>
using namespace std;

int main()
{
	int n;
	while(scanf("%d", &n) && n)
	{
		int temp;
		temp = n;
		for(int i = 2; i <= n; ++i)
			temp = temp * n % 9;
		if(temp == 0)
			printf("9\n");
		else
			printf("%d\n", temp);
	}
	return 0;
}

暴力求解(即把所有的数枚举出来找出规律)

以下为摘数学算法:              

        因为ab*ab=(10*a+b)*(10*a+b)=100*a*a+10*2*a*b+b*b=a*a+2*a*b+b*b=(a+b)*(a+b)

        abc*abc=(100*a+10*b+c)*(100*a+10*b+c)

                   =10000*a*a+2000*a*b+100*b*b+200*a*c+20*b*c+c*c

                   =a*a+2*a*b+b*b+2*a*c+2*b*c+c*c

                   =(a+b)^2+2*c*(a+b)+c*c

                   = (a+b+c)*(a+b+c)

          

        同理可以知道四位数,五位数也一样,

                即n*n的数根=n的数根*n的数根
#include <iostream>
using namespace std;
int main()
{
int n;
char s[20]="914942971915947978";
while(cin>>n&&n)
{
  cout<<s[n%18]<<endl;
}return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值