HDU2473 Junk-Mail Filter 【可删除的并查集】

33 篇文章 0 订阅
5 篇文章 0 订阅

HDU2473 Junk-Mail Filter


Problem Description

Recognizing junk mails is a tough task. The method used here consists of two steps:

  1. Extract the common characteristics from the incoming email.
  2. Use a filter matching the set of common characteristics extracted to determine whether the email is a spam.

We want to extract the set of common characteristics from the N sample junk emails available at the moment, and thus having a handy data-analyzing tool would be helpful. The tool should support the following kinds of operations:

a) “M X Y”, meaning that we think that the characteristics of spam X and Y are the same. Note that the relationship defined here is transitive, so
relationships (other than the one between X and Y) need to be created if they are not present at the moment.

b) “S X”, meaning that we think spam X had been misidentified. Your tool should remove all relationships that spam X has when this command is received; after that, spam X will become an isolated node in the relationship graph.

Initially no relationships exist between any pair of the junk emails, so the number of distinct characteristics at that time is N.
Please help us keep track of any necessary information to solve our problem.

Input

There are multiple test cases in the input file.
Each test case starts with two integers, N and M ( 1 ≤ N ≤ 1 0 5 , 1 ≤ M ≤ 1 0 6 ) (1 ≤ N ≤ 10^5 , 1 ≤ M ≤ 10^6) (1N105,1M106), the number of email samples and the number of operations. M lines follow, each line is one of the two formats described above.
Two successive test cases are separated by a blank line. A case with N = 0 and M = 0 indicates the end of the input file, and should not be processed by your program.

Output

For each test case, please print a single integer, the number of distinct common characteristics, to the console. Follow the format as indicated in the sample below.

Sample Input

5 6
M 0 1
M 1 2
M 1 3
S 1
M 1 2
S 3

3 1
M 1 2

0 0

Sample Output

Case #1: 3
Case #2: 2


题目大意就是让你支持两种操作,一个是把两个集合合并起来,另一个是把当前这个点和所在的集合分离开


思路是并查集维护,然后对于分离节点,我们考虑给每个点初始的父亲节点设为一个虚节点,然后在删除节点的时候我们直接把这个节点的虚父亲改了,就可以实现了


#include<bits/stdc++.h>
using namespace std;
#define N 5000010
int fa[N];
bool vis[N];
int n,m,cnt;
int Find(int x){
	if(x==fa[x])return x;
	return fa[x]=Find(fa[x]);
}
void Merge(int x,int y){fa[Find(x)]=Find(y);}
void Delete(int x){fa[x]=++cnt;}
int main(){
	int T=0;
	while(scanf("%d%d",&n,&m)&&(n||m)){
		memset(vis,0,sizeof(vis));
		cnt=n<<1;
		for(int i=0;i<n;i++)fa[i]=i+n;
		for(int i=n;i<N;i++)fa[i]=i;
		while(m--){
			char s[5];
			scanf("%s",&s);
			if(s[0]=='M'){
				int x,y;
				scanf("%d%d",&x,&y);
				Merge(x,y);
			}else {
				int x;scanf("%d",&x);
				Delete(x);
			}
		}
		int ans=0;
		for(int i=0;i<n;i++){
			int t=Find(i);
			if(!vis[t])ans++;
			vis[t]=1;
		}
		printf("Case #%d: %d\n",++T,ans);
	}
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值