HDOJ 5813 Elegant Construction



Elegant Construction

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 908    Accepted Submission(s): 373
Special Judge


Problem Description
Being an ACMer requires knowledge in many fields, because problems in this contest may use physics, biology, and even musicology as background. And now in this problem, you are being a city architect!
A city with N towns (numbered 1 through N) is under construction. You, the architect, are being responsible for designing how these towns are connected by one-way roads. Each road connects two towns, and passengers can travel through in one direction.

For business purpose, the connectivity between towns has some requirements. You are given N non-negative integers a1 .. aN. For 1 <= i <= N, passenger start from town i, should be able to reach exactly ai towns (directly or indirectly, not include i itself). To prevent confusion on the trip, every road should be different, and cycles (one can travel through several roads and back to the starting point) should not exist.

Your task is constructing such a city. Now it's your showtime!
 

Input
The first line is an integer T (T <= 10), indicating the number of test case. Each test case begins with an integer N (1 <= N <= 1000), indicating the number of towns. Then N numbers in a line, the ith number ai (0 <= ai < N) has been described above.
 

Output
For each test case, output "Case #X: Y" in a line (without quotes), where X is the case number starting from 1, and Y is "Yes" if you can construct successfully or "No" if it's impossible to reach the requirements.

If Y is "Yes", output an integer M in a line, indicating the number of roads. Then M lines follow, each line contains two integers u and v (1 <= u, v <= N), separated with one single space, indicating a road direct from town u to town v. If there are multiple possible solutions, print any of them.
 

Sample Input
  
  
3 3 2 1 0 2 1 1 4 3 1 1 0
 

Sample Output
  
  
Case #1: Yes 2 1 2 2 3 Case #2: No Case #3: Yes 4 1 2 1 3 2 4 3 4
题意:给你m个数第i个数的ai表示与i相连的城镇有ai个,让你构建一个无环有向图符合题意。
思路:首先题中说了有很多的只需要随便输出一个即可,所以我们只需让他们按照ai从小到大排列,然后从左向右依次遍历即可,例如ai为m,就是证明从终结点到i城镇有m条路
代码:
#include<bits/stdc++.h>
#include<stdio.h>
#include<string.h>
#include<algorithm>
#include<iostream>
#include<cstring>
#include<vector>
#include<map>
#include<queue>
#include<set>
#include<stack>
using namespace std;
struct Node
{
    int num,id;//id代表第几个城镇相当于i,num表示有几个城镇与id相连像当于ai

} num[1005];;

bool cmp(Node a,Node b)
{
    return a.num<b.num;//将数组按num大小从小到大排列
}
int main()
{
    int t;
    scanf("%d",&t);
    for(int m=1; m<=t; m++)
    {
        int n;
        scanf("%d",&n);
        for(int j=1; j<=n; j++)
        {
            int temp;
            scanf("%d",&temp);
            num[j].id=j;
            num[j].num=temp;
        }
        sort(num+1,num+1+n,cmp);
        int flag=1;
        for(int i=1; i<=n; i++)
        {
            if(num[i].num<=i-1)
            {
                continue;//如果num[i].num大于i-1则构不成有向图
            }
            else
                flag=0;
        }
        if(flag==0)
            printf("Case #%d: No\n",m);
        else
        {
            printf("Case #%d: Yes\n",m);
            int ans=0;
            for(int i=1; i<=n; i++)
            {
               ans+=num[i].num;
            }

            printf("%d\n",ans);
            for(int i=1; i<=n; i++)
            {
                for(int j=1; j<=num[i].num; j++)
                {
                    printf("%d %d\n",num[i].id,num[j].id);//
                }
            }
        }

    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值